Forums > MaxMSP

jit.cellblock -9 problem

October 16, 2007 | 6:32 am

i tested derek’s accusation, and it’s true- jit.cellblock won’t display most negative float numbers. what’s up with that?

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 132 146 46 196617 jit.print;
#P button 77 42 15 0;
#P user jit.cellblock 71 179 548 371 3 9 10 10 45 17 0 1 1 0 0 0 1 1 1 0 0 0 255 255 255 0 0 0 0 0 0 191 191 191 0 0 0 215 215 240 1 1 1 0 4 0 0 0;
#P newex 109 86 100 196617 jit.op @op – @val 0.5;
#P newex 109 113 111 196617 jit.op @op * @val 100;
#P newex 109 40 122 196617 jit.noise 1 float64 10 10;
#P connect 1 0 3 0;
#P connect 1 0 5 0;
#P connect 4 0 0 0;
#P connect 0 0 2 0;
#P connect 2 0 1 0;
#P window clipboard copycount 6;


October 16, 2007 | 7:46 am

If you increase the default cell width, the numbers show up. So, for
example, if I change the default cell width to 65, all of the numbers
show up. This is a problem with displaying cell contents that cannot
be "broken" properly. Another option, if you prefer, is to reduce
the default float precision of the cellblock – I’m not sure how much
precision you need, but that is an alternative that will allow you to
see more rows without scrolling.

[ddg]
Darwin Grosse


October 26, 2007 | 9:54 am

Darwin Grosse schrieb:
> Another option, if you prefer, is to reduce the default float
> precision of the cellblock

This seems to be insider knowledge, I couldn’t find anything in the help
file, the inspector or the manual how to change the default float
precision for cellblock (it might be well hidden)…
I think best would be if the display of floats in cellblock
automatically would follow exactly the same rules as the display in
float number boxes. Either cut them or do a float display correction…

I would call the momentary behaviour a design bug, and the proposed
changing of the width is an unusable workaround, not a solution…
(There is a reason why one would not want to make the width bigger than
the design of the patch would allow… ;-)

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


October 26, 2007 | 10:45 am

it’s in the hel of jitt.cellblock under STRUCTURE subpatch

by the way you should
send a message called

precision $1
from 0 to 8

you can also set them in the get ifo of the jitt.block object

i know as i did it yesterday

On Oct 26, 2007, at 11:54 AM, Stefan Tiedje wrote:

> Darwin Grosse schrieb:
>> Another option, if you prefer, is to reduce the default float
>> precision of the cellblock
>
> This seems to be insider knowledge, I couldn’t find anything in the
> help file, the inspector or the manual how to change the default
> float precision for cellblock (it might be well hidden)…
> I think best would be if the display of floats in cellblock
> automatically would follow exactly the same rules as the display in
> float number boxes. Either cut them or do a float display
> correction…
>
> I would call the momentary behaviour a design bug, and the proposed
> changing of the width is an unusable workaround, not a solution…
> (There is a reason why one would not want to make the width bigger
> than the design of the patch would allow… ;-)
>
> Stefan
>
> —
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>
>


Viewing 4 posts - 1 through 4 (of 4 total)