jit.gl.handle doesn't like send in Max6 anymore, worked in Max5

Mar 5, 2012 at 2:52pm

jit.gl.handle doesn't like send in Max6 anymore, worked in Max5

I just noticed that you can’t connect a jit.gl.handle to a jit.gl.render via a send or other object in Max 6. The scene gets all jumpy and out of control. This used to work in Max 5. Not sure if it was intended to or not though. (didn’t try any other objects than jit.gl.render)

#62148
Mar 5, 2012 at 7:01pm

you need to set @inherit_transform 1 on your gl.handle.
this is done automatically when connecting directly to a gl.render object, but not when sending through send and receive.

#224482
Mar 5, 2012 at 9:00pm

I had that in my Max5 patch but it doesn’t work for me in 6. this patch misbehaves for me:

– Pasted Max Patch, click to expand. –

gl.handle is in the 3D-setup subpatch. strangely, also the axes message to gl.render doesn’t work.

#224483
Mar 6, 2012 at 7:17am

ok, thanks for the patch.
i see what’s going on here. the gl.handle automatically sets @auto_handle 1 when it’s not connected to any gl objects. the solution would be to explicitly set @auto_handle 0 in the max box.

however, currently there is a bug that’s causing this not to work. so in this case you need to send the message “auto_handle 0″ to the gl.handle object with a loadbang message.

i will get this bug squashed for the next update.

thanks again for pointing this out.

#224484
Mar 6, 2012 at 9:00am

you’re welcome!

#224485

You must be logged in to reply to this topic.