Forums > Max For Live

jit.gl.imageunit and M4L

March 29, 2011 | 4:35 pm

I would like to use the object jit.gl.imageunit inside Max for live. It is working in max standalone but it crashes all the time inside Live.

Did anyone have this issue?

cheers


March 30, 2011 | 2:03 pm

Same here, I noticed it crashes after reconnecting the source video stream, which is probably happening in M4L automatically, it needs to reset then. Still, issue not solved, anyone?


March 30, 2011 | 4:18 pm

Hi folks,

Can you send along a very simple device which exhibits the issue? In a basic test, I see no crashes, so I’ll need something to repro the issue. Please send along your version of Max, version of Live, OS, and computer model.

thanks,
-Ben


March 30, 2011 | 5:59 pm

Hi Ben

This is the max patch

– Pasted Max Patch, click to expand. –

and attached to this message the m4l device.

It crashes on both computers as soon as you start the qmetro.

Max 5.1.7
Live 8.2.1
Mac 10.6.5, hackintosh Mac Pro 2.33 GHz Quad-Core intel Xeon, 8 Go, GeForce GT220

Max 5.1.6
Live 8.2.1
Mac 10.6.6, Macbook Pro, 2.8 GHz Intel Core 2 duo, 4 Go, NVIDIA GeForce 9400M

Cheers!

Attachments:
  1. test.amxd

March 30, 2011 | 6:40 pm

Hi Julien,

Hmm, seems fine here on both 10.5 and 10.6. I recommend doing a clean install of the latest versions of both Live (8.2.2) and Max (5.1.8):

http://www.cycling74.com/downloads

http://www.ableton.com/download

The other thought is that something could be funky with your preferences. Trash em:

~/Library/Preferences/Max5 Preferences

Maybe there is an incompatibility with one of the imageunits you have installed? What do you have installed?

Let me know how you get along after this.

-Ben


March 30, 2011 | 9:35 pm

Hi

Uploaded max and live and trashed max 5 preferences folder on both computers. It still crashes.

I did not install any imageunits. I tried to load all the effects and 6 of them seem to work; all the others make live crash.

effects which work:
Kaleidoscope
Maximum
Median
Minimum
Mod
Flash

Would you need a crash log?

Thanks again.


March 30, 2011 | 9:42 pm

Hi Julien,

Hmm, seems like a machine specific issue. A crash log would be great. Feel free to send it to support at cycling74 dot com.

-Ben



tep
September 15, 2011 | 6:28 am

Well,

jit.gl.imageunit still instantly crashes here, in MaxMSP as in M4L on many effects / processes : kaleidoscope, mask to alpha …
os X 10.6.8, clean install & preferences removed …
?


Viewing 8 posts - 1 through 8 (of 8 total)