Forums > Jitter

Jit.gl.mesh inputs

March 21, 2010 | 1:36 am

Does anyone have a patch that displays the inputs of jit.gl.mesh and how to effect the parameters.. does not seem to be clear info on the subject on forum or anywhere.
Thanks..


March 23, 2010 | 6:24 pm

still no response?.. amazing.. I have researched forum and rest.. found lots of patches using jit.gl.mesh and have used it myself with ease. However usually only the first (vertex array) inlet is used.. one or two of the other inlets are sometimes used but there is no effective documentation describing
why the 9 inlets are there and how to make use of them. I have been able to work with shaders( that come with max) on the mesh.. very nice .. geometry shaders would not work however. got error that could not bind to vertex..I am working with models.. could that be issue?


March 23, 2010 | 11:56 pm

you will probably get a better response if you ask a more specific question.
in the meantime, here is a patch which shows how to unpack the matrixoutput of jit.gl.model, into the postion, texcoord, and normal inputs to jit.gl.mesh

btw, geometry shaders are not yet supported by jitter.

– Pasted Max Patch, click to expand. –

March 25, 2010 | 6:39 am

Thanks for answering Rob , That solves the geometry shader issue.. I thought it might be possible to effect the geometry of a model drawn to a mesh by triggering the inputs of the mesh object individually but maybe that’s not possible..( I am finding other avenues ) I have been able able to manipulate the mesh color coordinates as well as send my textures to the mesh so they can mix with shaders which is great…(would be better if I could write my own but that’s down the line.. there does seem to be a few to borrow though) another issue I have is I am sending more than one model to the mesh .. The first model is textured correctly and I can switch it although I can’t adjust the coordinates…. The second model’s texture is mixed and seems sort of a feedback thing.. but don’t seem to be able direct the models textures as can’t seem to name the textures independently to the mesh..


Viewing 4 posts - 1 through 4 (of 4 total)