jit.gl.model example for nodes / skeleton

Oct 26, 2011 at 12:31am

jit.gl.model example for nodes / skeleton

I managed to export a model from maya as .dae
Could someone provide me with a maya file that contains a nodes, bones or skeleton hierarchy that i can retrieve in Max6?
so I can link nodenames to jit.anim.node or jit.gl.node

It seems that the preview video contains such a model

thanks

#59551
Oct 26, 2011 at 2:07am

well, I managed to find the models at:

http://www.warriorhut.org/spring/mods/modeltest/files/Objects3D/

seems that the ‘getnodenames’ and ‘gettexnames’ messsage does not work

#214325
Oct 26, 2011 at 4:11am

About Collada inner scale:
When I export a model from maya in .dae, if the preferences units are set to meters, the exporting collada file automatically includes a scale 0.01 0.01 0.01 for all top hierarchy objects.

the only solution is to set units to cm and export as cm, right?
So the model is loaded correctly in jit.gl.model

I conclude that the ‘working unit’ of max6 is cm.
Or it’s all relative?

Is there a workaround to compensate for this scale .01 in the import?

#214326
Oct 28, 2011 at 4:00am

in the release version, those message names (getnodenames and gettexnames) should work.

if you load a file with bone-nodes, you can send the message “copynodestoclipboard” to the jit.gl.model, to create in the clipboard, a hierarchical structure of jit.anim.node objects, that mirror the model’s node structure.
once you paste them in the patch (or a sub-patch) they will bind to the model’s inner nodes, allowing you to control them.

the jitter opengl world has no concept of meter or cm, only units. whatever you set your unit to be in the exporter, is what it will be in jitter.

also, the @normalize attribute of jit.gl.model is enabled by default, so models are scaled to be normalized across the three dimensions when the model is loaded. this may be why your exports are not scaled as you think they should be.

let me know if you have any other questions.

#214327

You must be logged in to reply to this topic.