jit.gl.node bug : losing texture

Mar 26, 2013 at 2:28pm

jit.gl.node bug : losing texture

Hi

I have a simple patch showing the problem, encountered on a macbook pro 2.8Ghz Intel Core 2 Duo with 4Go 1067MHz DD3 Ram, OSX 10.7.4, with Max6.0.8 and Max6.1.0.
FYI, I searched the forum for similar pb and the problem encountered by hc gilje (cf. http://cycling74.com/forums/topic.php?id=41590 ) is *not* happening on my computer, which display the dozer video fine.

– Pasted Max Patch, click to expand. –

In case the problem do not show up on your comp, here are 2 snapshots of mode “Direct” and mode “through bus” respectively :

Attachments:
  1. Capturedecran20130326a15.11.07.jpg
#67349
Mar 26, 2013 at 2:47pm

Happens to me too. Not sure if it’s a bug or faulty patching.

OSX 10.8.2, nvidia GTX670, Max608

#242311
Mar 26, 2013 at 2:51pm

yep. not sure too. It seems there are more than one way to achieve a video bus system, and not all solutions will yield same results.

Prior to jit.gl.node, there were patches posted by Vade and Andrew Benson involving the to_texture-to-render method, but I cannot find any updated version involving jit.gl.node.

I’d really love to get to a similar result like what I am used to with the render-to-texture method (without the performance hit mentionned in that thread : http://cycling74.com/forums/topic.php?id=45004). I mean :

- Render each GL object to 0 to N destination.
- being able to swicth dynamically between what is rendered where
- being able to render a destination to itself to achieve nice feedback effects (that one can easily and powerfully modulate with camera setting)
- have the jit.gl.node, jit.gl.camera, jit.gl.whatever in distant patchers (no patchcord between them)

Can we have the opinion of a C74 fellow on the topic ? (as well as a nice Jitter Recipe :) ? )

#242312
Mar 26, 2013 at 5:37pm

Salut Vincent
It works for me if i give the good destination name to ‘jit.gl.texture” (main/bus1)
mathieu

#242313
Mar 26, 2013 at 5:50pm

yeah !
merci Mathieu !

#242314

You must be logged in to reply to this topic.