Jit.gl.plato matrixoutput.

Jul 22, 2012 at 2:26pm

Jit.gl.plato matrixoutput.

Hello forums!

Should jit.gl.plato output its matrix the same way gl.gridshape and gl.nurbs does, with matrixoutput set to 1? I’m looking at the documentation and the forums and i can’t find information about it other than jit.gl.plato reference saying it should.

Another thing i’m having trouble with is when i capture a gl.plato with gl.node capture 1 attribute and send it to a videoplane, the lighting doesn’t follow like it does doing the same thing with gl.gridshape. I’m running Max 6.0.5 on MBP 7,1 OS X 10.6.8. Thank you!

– Pasted Max Patch, click to expand. –
Jul 22, 2012 at 7:45pm

you should set the gl.mesh @draw_mode attribute to triangles (instead of the default of tri_grid).

you may have better luck with the lighting if you send only the three position planes (eg, send the matrix to a jit.pack 1 @jump 3 before sending to the gl.mesh) and enabling @auto_normals on the gl.mesh.

please post a patch demonstrating the problem you are seeing with gl.node.

Jul 22, 2012 at 9:24pm


Thanks for the new information. When i capture gl.gridshape to a jit.gl.node, if i have the lighting enabled, the lighting stays enabled when “projected” to a videoplane. This doesn’t happen with gl.plato though. The problem i have is that i cant see the edges of the “solids”. Thanks again for the new info about plato and mesh!

– Pasted Max Patch, click to expand. –
Jul 26, 2012 at 10:41am


Now it’s working! I draw the solids with triangles on a mesh and capture that with my node. I wouldn’t necessary make a music video out of this patch yet but who knows :)

Edit: I guess i dont even need that jit.pack there..

– Pasted Max Patch, click to expand. –

You must be logged in to reply to this topic.