Forums > MaxMSP

jit.gl.slab no interpolation?

May 2, 2014 | 3:06 pm

is it possible to set jit.gl.slab to no interpolation? if so, how?

thanks :)


May 5, 2014 | 4:23 pm

Would you please be more specific? And a simple patch with your question is best.

Meanwhile, in a shader that runs in jit.gl.slab, you can specify the way that data is passed from vertex to the fragment shader using GLSL Interpolation Qualifiers like: smooth, flat, noperspective.


May 5, 2014 | 5:49 pm

I’m using td.rota.jxs in a jit.gl.slab and I need it to perform NO interpolation on the image. I don’t really understand about the shaders’ world in depth. Do you mean that it’s not about jit.gl.slab but about the design of the shader which would make this possible?


May 6, 2014 | 2:33 am

That is potentially true. A main purpose of jit.gl.slab is to execute a GLSL shader on texture data…therefore the code in the shader defines a very very large portion of the behavior. The natural behavior of much of GLSL is to interpolate values. It is technically possible to not do that.

The @adapt and @interp attributes might help you on various objects. Several of the features in td.rota.jxs also have jit.xxxxx objects. For example, scaling and subsectioning can be done with jit.matrix and you can turn the interpolation off. Note, those calculations are done on the CPU rather than the GPU.

I have no example from you to advise. SOme more random ideas. Try sending the message "sendoutput filter nearest" to the jit.gl.slab. Setting @filter=nearest on your jit.gl.texture.

  • This reply was modified 2 months by  diablodale.

Viewing 4 posts - 1 through 4 (of 4 total)