jit.gl.text2d and unicode

Apr 1, 2013 at 12:33pm

jit.gl.text2d and unicode

Hi!

It seems to me that jit.gl.text2d does not display a large number of (existing) unicode characters. For instance, if I try to have the text “Sħe sat” displayed with font Georgia, the “ħ” letter (though existing: a simple message box displays it properly) is replaced by a square.

Does anybody have a clue?

Thanks,
Daniele

#67460
Apr 7, 2013 at 12:13am

…has anybody else had this issue?…

#242686
Apr 7, 2013 at 9:30am

what kind of font do you use ?
what os you are using ?

not every unicode font has all characters build in.
if you are on windows try the font Arial Unicode MS.

#242687
Apr 7, 2013 at 3:07pm

As I originally wrote, I’m using Georgia font, but the issue is common to many other font. I’m on Mac OS X 10.6.8. I’m very sure that the font has the Unicode ħ character built in, cause I can see it in any other application (or directly using PopChar, for instance).

#242688
Apr 7, 2013 at 3:08pm

(and moreover I can perfectly see it in a ordinary message box, whose font is set to Georgia…)

#242689
Apr 7, 2013 at 6:16pm

hi
may be post a patch …
How do you write the text to “jit.gl.text2d”?
via matrix, via messages ?

#242690
Apr 8, 2013 at 12:23am

Hi matmat. Below you have an example, with text sent via messages.
I suppose I can’t send via matrix either, since all the examples I have found in the doc use char matrices (not enough for full unicode depth…)

Any advice is really welcome…

Daniele

– Pasted Max Patch, click to expand. –
#242691
Apr 8, 2013 at 6:13am

hi danieleghisi,

seems that there is a bug in jit.gl.text2d.
perhaps it is better to use jit.mgraphics.

it seems to display your text correct.

best,
kugelschreiber

– Pasted Max Patch, click to expand. –
#242692

You must be logged in to reply to this topic.