jit.gl.text2d RECIPE 28 "Subtitles" BROKEN in Max 6 — WHY?

Mar 16, 2012 at 10:35pm

jit.gl.text2d RECIPE 28 "Subtitles" BROKEN in Max 6 — WHY?

I am trying to do subtitles as in Recipe #28, but this seems broken in Max 6.

If one reverses the rendering order, banging the jit.gl.text2d object before the video plane, the text will appear over the video BUT every letter of text has a strange non transparent background bounding box which is impossible to remove regardless of blend mode settings etc.

Any tips or workarounds appreciated – seems like a bug in the the object itself?

Attachments:
  1. 28.SubTitle.maxpat
#62427
Mar 16, 2012 at 11:14pm

When that patch was written, depthbuffering off used to be default on Mac, so it was naively assumed when the patch was written that depth-testing wouldn’t happen. To fix it, you can do @depth_enable 0 on the jit.gl.text2d and use the @layer attribute to manage draw order. Let me know if that makes sense.

#225507
Mar 17, 2012 at 1:43am

Thanks Andrew — that was truly righteous.

#225508

You must be logged in to reply to this topic.