jit.gl.texture @adapt 1 question

Aug 22, 2006 at 7:06pm

jit.gl.texture @adapt 1 question

Hello

Im running max 4.6 and jitter 1.6 release. Ive got a questions about
@adapt 1 with jit.gl.texture.

With @adapt 1, shouldnt the dim match the dest_dim of the texture?

I find I have to explicitly set the dim size to get anything other
than “@dim 256 256″ initially when using @adapt 1

It appears that dest_dim is being correctly set, but my textures look
bad. If I remove @adapt 1 and force something “@dim 1280 720″, openGl
returns to its glorious resolution.

Is this a bug, or am I misunderstanding what @adapt 1 ought to do?

below is an example patch:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P comment 392 328 297 196617 < - clicking me after the message above
doesnt “do” anything.. ?;
#P message 331 320 43 196617 adapt 1;
#P message 331 299 114 196617 adapt 0 , dim 1280 720;
#P window linecount 3;
#P message 341 247 278 196617 < - resise the window to be large , and
note how the texure ‘pixelates’ poorly.. Check jit.gl.texures
attributes to notice @dest_dim something like 320×240 , where dim is
256 256;
#P window linecount 2;
#P newex 228 129 340 196617 jit.gl.gridshape dimdim @shape sphere
@automatic 0 @capture target @blend_enable 1 @depth_enable 1
@smooth_shading 1 @lighting_enable 1;
#P toggle 26 61 15 0;
#P window linecount 1;
#P newex 205 210 277 196617 jit.gl.videoplane dimdim @transform_reset
2 @automatic 0;
#P newex 205 175 296 196617 jit.gl.texture dimdim @colormode uyvy
@adapt 1 @name target;
#P newex 26 86 51 196617 qmetro 2;
#P newex 26 132 58 196617 t b b erase;
#P newex 159 259 165 196617 jit.window dimdim @depthbuffer 1;
#P newex 26 260 100 196617 jit.gl.render dimdim;
#P comment 451 300 145 196617 < - click me to "fix" pixelation;
#P connect 7 0 4 0;
#P connect 4 0 3 0;
#P connect 3 0 1 0;
#P connect 3 2 1 0;
#P connect 3 1 5 0;
#P fasten 11 0 5 0 336 338 139 338 139 152 210 152;
#P fasten 10 0 5 0 336 316 147 316 147 152 210 152;
#P connect 3 1 6 0;
#P connect 5 0 6 0;
#P connect 3 1 8 0;
#P window clipboard copycount 13;

v a d e //

http://www.vade.info
abstrakt.vade.info

#27257
Aug 22, 2006 at 11:27pm


On Aug 22, 2006, at 12:06 PM, vade wrote:

> Im running max 4.6 and jitter 1.6 release. Ive got a questions
> about @adapt 1 with jit.gl.texture.
> With @adapt 1, shouldnt the dim match the dest_dim of the texture?

@adapt 1 is only respected in jit.gl.render’s to_texture command. It
is not respected in @capture. We could perhaps change this in a
future version, but this is the way it currently is designed.

-Joshua

#82273
Aug 23, 2006 at 12:19am

Ah, fair enough. I suppose I made an assumption.

Can we make this a feature request?

Thanks for the quick reply.

v a d e //

http://www.vade.info
abstrakt.vade.info

On Aug 22, 2006, at 7:27 PM, Joshua Kit Clayton wrote:

>
>
>
> On Aug 22, 2006, at 12:06 PM, vade wrote:
>
>> Im running max 4.6 and jitter 1.6 release. Ive got a questions
>> about @adapt 1 with jit.gl.texture.
>> With @adapt 1, shouldnt the dim match the dest_dim of the texture?
>
> @adapt 1 is only respected in jit.gl.render’s to_texture command.
> It is not respected in @capture. We could perhaps change this in a
> future version, but this is the way it currently is designed.
>

#82274

You must be logged in to reply to this topic.