jit.gl.texture: setting active texture target.: GL Error: Stack overflow

Sep 7, 2010 at 9:15am

jit.gl.texture: setting active texture target.: GL Error: Stack overflow

Hello.

I have texcoord and vertex data(osc message) coming from outside max.

and trying to draw multiple polygons using those data.

I do not have jit.gl.texture object in patcher.

I print every single messages and they are good.

like this ;

print: reset
print: glpushmatrix
print: gltranslate 0. 0. 0.
print: glcolor 1. 1. 1. 1.
print: glbindtexture crash
print: glbegin polygon
print: gltexcoord 0.234375 0.
print: glvertex -0.586803 -0.828428 -0.000001
print: gltexcoord 0. 0.
print: glvertex -1.10457 -0.828428 -0.000001
print: gltexcoord 0. 1.
print: glvertex -1.10457 0.828428 -0.000001
print: gltexcoord 0.228125 1.
print: glvertex -0.60061 0.828428 -0.000001
print: glend
print: glpopmatrix
print: glpushmatrix
print: gltranslate 0. 0. 0.
print: glcolor 1. 1. 1. 1.
print: glbindtexture crash
print: glbegin polygon
print: gltexcoord 0.45 0.
print: glvertex -0.110457 -0.828428 -0.000001
print: gltexcoord 0.364062 0.
print: glvertex -0.300305 -0.828428 -0.000001
print: gltexcoord 0.234375 0.
print: glvertex -0.586803 -0.828428 -0.000001
print: gltexcoord 0.228125 1.
print: glvertex -0.60061 0.828428 -0.000001
print: gltexcoord 0.446875 1.
print: glvertex -0.117361 0.828428 -0.000001
print: glend
print: glpopmatrix

I get “jit.gl.texture: setting active texture target.: GL Error: Stack

overflow” message frequently.

Window flickers when it happens or polygon doesn’t draw correctly.

Can someone tell me what this error message is?

thanks in advanced

jin

#52202
Sep 7, 2010 at 11:28pm

It could be that the matrix mode is not always set to modelview when you are calling glpushmatrix and glpopmatrix. For example, when binding textures, the matrix mode can be set to the texture matrix.

Try adding glmatrixmode modelview before every glpushmatrix and glpopmatrix call. If that doesn’t work. Please provide us with a simple and complete example we can test (don’t forget machine/os/version specs).

Thanks,
Joshua

#187589

You must be logged in to reply to this topic.