Forums > Jitter

jit.glue mismatch type?

November 15, 2007 | 9:42 pm

I am curious what is going on in the following patch; it seems like a bug.

jit.glue reports the error "mismatch type." If I add the attribute @type float32 it reports "mismatch plane." If I add @planecount 1, then it is happy.

My mental model says that jit.glue defaults to 4 plane char matrices, and adapts to others, but complains? This is cosmetic, but annoying.

Mac OS 10.4.10, Macbook Pro 2 gig, Max 4.6.3, Jitter 1.6.3

Thanks,

mz

#P window setfont "Sans Serif" 9.;
#P user jit.fpsgui 206 439 60 196617 2;
#P user jit.fpsgui 455 352 60 196617 2;
#P user jit.fpsgui 392 351 60 196617 2;
#P user jit.fpsgui 330 350 60 196617 2;
#P window linecount 1;
#P newex 206 65 30 196617 t b b;
#P newex 206 45 48 196617 loadbang;
#P message 259 96 43 196617 1. 1. 1.;
#P newex 259 128 63 196617 jit.fill foo 0;
#P user jit.fpsgui 383 214 60 196617 4;
#P user jit.fpsgui 320 214 60 196617 3;
#P user jit.fpsgui 258 213 60 196617 2;
#P button 206 95 15 0;
#P newex 206 394 98 196617 jit.glue @columns 3;
#P newex 206 300 118 196617 jit.scissors @columns 3;
#P newex 206 181 251 196617 jit.matrix foo @type float32 @planecount 1 @dim 1 3;
#P connect 1 2 2 2;
#P connect 1 2 13 0;
#P connect 1 1 2 1;
#P connect 1 1 12 0;
#P connect 1 0 2 0;
#P connect 1 0 11 0;
#P connect 2 0 14 0;
#P connect 0 0 1 0;
#P connect 0 0 4 0;
#P connect 0 0 5 0;
#P connect 0 0 6 0;
#P connect 8 0 7 0;
#P connect 10 1 8 0;
#P connect 3 0 0 0;
#P connect 10 0 3 0;
#P connect 9 0 10 0;
#P window clipboard copycount 15;


Viewing 1 post (of 1 total)