jit.grab problems in Max 6 on PC

Nov 3, 2011 at 2:55pm

jit.grab problems in Max 6 on PC

Hello,
I have been testing the jit.grab object in Max 6. I keep running into errors. Currently I am getting this error in Windows 7 x64 with a Logitech Pro C910 trying to use the jit.grab help file. (I also have installed (and uninstalled) many other tools to work with webcams in the past such as vdig 1.01, skype, google talk, and another one called webcamsplitter.)

0(NAME OF DEVICE HERE):Problem finding WinVDIG Video Renderer. Did you install as Admin?

I believe this object is supposed to work for both mac and pc by automatically choosing either a quicktime or directX grab. It seems like it is trying to use quicktime even though I am on a pc. Do you think that the new object still has bugs, or is there a problem with the software on my system? Thanks for your advice!

#59768
Nov 3, 2011 at 3:24pm

I’m by no means a pro (or even amature) but a couple things come to mind. On mac, I use jit.qt.grab; also have you tried connecting a “settings” message box to it and selecting a different source???

Sorry if I’m of no help!

#215116
Nov 3, 2011 at 3:33pm

Yeah jit.qt.grab seems to work great on my mac, but I really want to create patches that work cross platform. I have read in the forums that people figured out how to make a switch that knows if it is on a mac or pc and uses the correct grab object, but I was hoping this new grab object will have feature parity across both platforms.

Also, I don’t think you can use the settings message until a webcam is initialized, and the error message happens just before this.

Thanks

#215117
Nov 3, 2011 at 10:52pm

Don’t forget that with a pc you have to type jit.dx.grab…

#215118
Nov 7, 2011 at 10:23pm

jit.grab is a new cross platform object in max 6, it is supposedly designed to correctly choose whether to use jit.dx.grab or jit.qt.grab. I am still trying to see if people are having luck using it. I still don’t have it working.

#215119
Nov 10, 2011 at 4:50pm

Had the same problem with the first version of 6, works fine now with 6.0.1 as far as I can tell

#215120

You must be logged in to reply to this topic.