jit.matrix exportimage set jpeg quality without dialogue

Dec 7, 2009 at 2:53pm

jit.matrix exportimage set jpeg quality without dialogue

Hi all,
I’m making a patch which renders out images using two jit.movies plugged into an alphablend and out to a jit.matrix. So basically making composite images out of one jpeg and one transparent png via the two movie objects through an alphablend.

In order to automate this process for large numbers of images, I would like to set the jpeg quality of an exportimage command to the jit.matirx to maximum, by default I seem to be getting medium.
If I use the dialog once, than all subsequent images use the same quality setting (which I can live with), but I would very much like to do this automatically.

Is there a way to pass this setting to the matrix object without having to set it using the save dialogue???

example patch:

– Pasted Max Patch, click to expand. –
Sep 3, 2010 at 12:12am

same question
any workaround ?

Sep 3, 2010 at 2:05am

I believe this is a current limitation of the exportimage message. However, you might be able to get away with using the exportmovie message instead. Does this work for you?

– Pasted Max Patch, click to expand. –
Dec 4, 2010 at 11:41pm

I’ve used the exportmovie message workaround. It sort of works. The images open fine in QuickTime player and Photoshop. Finder, Preview and other image viewers do not display the images. I have already batch changed the file creator etc. That does not fix it. Any thoughts on how to make these images behave like ‘normal’ jpegs?

Btw, I think another workaround might be to use the exportimage message with the export dialogue for the first export, then remove the force dialogue flag – it seems the options ‘stick’.

Anyhow, thoughts on how to fix the 100+ strangely behaving jpegs I have now?

Thank you!

Jun 22, 2011 at 2:02am

i found a workaround first exporting using exportimage, not exportmovie, to png which is a lossless format then using the sips terminal command using aka.shell…
something like this: “sips -s format jpeg -s formatOptions 90 bugger.png –out bugger.jpg”


You must be logged in to reply to this topic.