jit.matrix.mxo broken in 5.1.4

May 1, 2010 at 10:30am

jit.matrix.mxo broken in 5.1.4

hello,

since the 5.1.4 update. you can not read .jxf files
directly with an absolute path anymore.
(message: read myAbsolutepath/myMatrix.jxf)
you get the following error:
jit.matrix: can’t find file myAbsolutepath/myMatrix.jxf

it works, if you use a read message and select
it manualy with the filechooser.

if i replace the 5.1.4 version of the jit.matrix.mxo
with the 5.1.3 version, everything works as expected.

tom

#50105
May 3, 2010 at 11:14am

no ideas ?

here is a smal patch, which is a demonstration of the bug:

– Pasted Max Patch, click to expand. –
#179883
May 3, 2010 at 2:59pm

I can’t reproduce this, it works ok for me in 42462 on Mac

#179884
May 3, 2010 at 3:56pm

strange …
i am also at 42462. mac osx 10.5.8, MacBook Pro 15″, MacBookPro2,2

i try to download the update again and install it …

#179885
May 3, 2010 at 7:45pm

it is still not working on my machine.
creation date of the jit.matrix.mxo is 29th of may 2010.
no additional searchpath …
this is definitly a bug !

#179886
May 4, 2010 at 9:14am

i can confirm there’s something strange.
the write message followed by a symbol works. but the read message followed by the same symbol does not. (in 42462)

it returns :

jit.matrix: can’t find file /Users/G/Desktop/truc.jxf
print: read /Users/G/Desktop/truc.jxf -1

this is definitely a bug.

g

#179887
May 4, 2010 at 6:09pm

Thanks for the report. This is now fixed and we hope to provide an update with the installer soon. In the meantime, here is a fixed version, which *also* works with writing with absolute paths, something which was a problem before.

#179888
May 5, 2010 at 12:44am

And here’s a fixed windows version in the meantime.

#179889
May 5, 2010 at 10:36am

the mac version works now on my machine.
thanks a lot joshua for the fast fix !

tom

#179890
May 5, 2010 at 2:54pm

Thanks a lot for this fix. Was just going crazy trying to work out what was wrong with it.

#179891

You must be logged in to reply to this topic.