jit.net.send – matrix 640 x 480 sent over another computer

Feb 20, 2010 at 10:39pm

jit.net.send – matrix 640 x 480 sent over another computer

Hello

I trying to separate my video capture on another computer so
I can increase my FPS for process on the second computer.

I’m using jit.net.send to send a 1280 x 480 matrix (luma mode)
Sice I have 2 cameras I have combined 2 images (640 x 480 each) with jit.glue
and separated them on the receive computer with jit.scissors

I have a lot of latency.
My FPS drops down to 3fps on my second computer.

Is that normal ?

What I am doing wrong ?

Exemple patchs:

Patch_net_send

– Pasted Max Patch, click to expand. –

Patch_net_recv

– Pasted Max Patch, click to expand. –

Marie-Hélène

#48656
Feb 21, 2010 at 5:18pm

your matrix is just too big. Unless you are doing a lot of processing in the sending computer before you send the matrix on, you aren’t going to gain anything by trying to pass so much data over a network, and you may even lose. At 1280 x 480 1-plane matrix is about 614 kB. which is a lot to push over a network 20+ times a second.

Your only real options are to pass less data, and use the best hardware you can get — gigabit router, wired connection. I can get about 24fps on a 1-plane 320×240 matrix using the hardware described above, but that is only 76 kB/frame, passing data between 2 new Mac minis.

hth,

M

#174894
Feb 21, 2010 at 6:22pm

Thank you Mattyo

I guess I’ll have to cut down on certain things !

Marie-Hélène

#174895

You must be logged in to reply to this topic.