jit.phys slow down to stop

Nov 8, 2012 at 11:02pm

jit.phys slow down to stop

Hi, does anyone know why with friction 0. and dumping 0. 0. my ball slow down to stop?
Thanks

– Pasted Max Patch, click to expand. –
#65121
Nov 9, 2012 at 9:55pm

not sure why this happens, but make sure you check out the phys.body.velocity example patch that demonstrates how to query and control the velocity of a rigid-body:
Max6/examples/jitter-examples/render/physics/phys.body.velocity.maxpat

you probably want to make sure you are upgraded to 6.0.8 too.

#234751
Nov 10, 2012 at 9:04am

Thank you this solves my problem :)

#234752
Nov 11, 2012 at 12:08am

Controlling velocity is a good workaround but maybe it is better fix the problem around restitution
I searched in the Bullet forum and i found this thread http://bulletphysics.org/Bullet/phpBB3/viewtopic.php?f=9&t=7922&hilit=restitution
the administrator speak about:
“enable split impulse, it will prevent the added energy (velocity) from penetrations.
Code:
m_dynamicsWorld->getSolverInfo().m_splitImpulse = true;”

Is possible to control split impulse in jitter?
Thanks

#234753
Nov 12, 2012 at 5:33pm

thanks for digging that up!
i will look at implementing this as an option to phys.world.

#234754
Nov 12, 2012 at 6:26pm

I’m happy if this can help you
I wait for news
thanks

#234755
Mar 1, 2013 at 12:50pm

Hi, I’m looking for a solution to disable object penetration
here a simple example of the problem, I would like the ball doesn’t pass through the plane.
Thank you for your help

– Pasted Max Patch, click to expand. –
#234756
Mar 1, 2013 at 10:53pm

hi
you could increase “fixedtimestep” and “maxsubsteps”
there is a good explanation here :

http://cycling74.com/forums/topic.php?id=38167

– Pasted Max Patch, click to expand. –
#234757
Mar 1, 2013 at 11:09pm

Thanks so much

#234758

You must be logged in to reply to this topic.