jit.pwindow does not follow the scrolling of the max window (bug?)

Mar 30, 2010 at 7:41pm

jit.pwindow does not follow the scrolling of the max window (bug?)

Hi!

In my patch I've a jit.pwindow, to which I draw using opengl. When I scroll the patch window, either with the scroll bars or using my mouse's scroll wheel, the contents of the jit.pwindow are static, even though it's representation in the max window is moved!

I'm running in Max 5.1.3, but have had this issue since Max 4.xx.

I've lived with it this far, but now I want to distribute an application that is too big for the screens of my intended users, thus requiring them to scroll, and this bug(?) prevents me from doing that, since the jit.pwindow will be left lingering over the programs controls when the users scroll, making the program unusable.

I've attached a screen-shot of the problem.

Below is a max-patch (simply the help patch for jit.gl.render), with a very large pwindow that is the target of opengl rendering, so that you can see for yourselves.

I hope there's a solution to this…

Thank you!

– Pasted Max Patch, click to expand. –

[attachment=128570,308]

Attachments:
  1. jit.pwindow_stuck.JPG
#49435
Mar 30, 2010 at 11:15pm

I have now tested the patch on an additional WinXP PC, as well as one of the latest Macbook models (running OSX).

All three computers consistenly behave in the same manner, ruling out that it may be an issue with my graphics drivers/computer.

#177586
Apr 2, 2010 at 2:03am

I have the same problem, which makes it pretty difficult when working on a patch with a big jit.pwindow. It doesn’t scroll like everything else does (“one of these kids is doing his own thing…”) … it only is fixed when I go back into locked mode. So many of my objects that I need to work on are hidden by this seemingly immovable pwindow (yes you can move it, but its “real” coordinates—like the ones you can grab and drag—are not the same as the on-screen ones, after you window-scroll… you think you are grabbing it, but there’s really nothing there). Is there some setting I don’t know about? Please enlighten!

#177587
Apr 2, 2010 at 2:17am

This will be fixed for the next update. Apologies for the hassle in the meantime.

-Ben

#177588
Apr 2, 2010 at 8:05pm

Great! Was wondering if I had something set wrong. Good to know.

#177589

You must be logged in to reply to this topic.