Forums > Jitter

jit.qt.broadcast->darwin streamings server->anyone

March 24, 2007 | 3:36 am

Hello,

I’m trying to send unicast, video-only stream using jit.qt.broadcast
from behind a NAT to a Darwin streaming server somewhere on the
internet, wich should make stream available to anyone interested.
My problem is that I’m the only person on whole internet who can
receive the stream from darwin streaming server, and that makes my
non-existant ip one of the loneliest on the planet, please help!

here’s what I’ve tried so far:

i’ve done random tests with h263 and mpeg4 codecs, but latter decided
to stick to mpeg4 for all programs and try the following :

streaming from apple’s quicktime broadcaster, using automatic unicast
-> everything ok, lot of people all over the world could see the stream;
streaming from apple’s quicktime broadcaster, using manual unicast
and manually ulpoaded .sdp file to DSS -> same as above:all ok;

streaming from jitter, jit.qt.broadcast, using unicast and setting
identical parameters as in apple’s broadcaster, using previous sdp,
or uploaded one written by jitter->not ok: I was the only one who
could access the stream. I’ve started Activity Monitor to look at
network traffic, and it seemed that packets were being sent to Darwin
Streaming Server, but I’m not 100% sure on this. If open I the rtsp://
url/sdp from DSS, it seems that there is some incoming network
traffic, so it seems like the data is travelling from my computer to
DSS and back to me(the stream stops if I disconnect from internet).
I gave the patch to a friend with PPC, but he had the same results:
only he could see his stream.
If someone else opens the stream, Quicktime player would connect, but
it would do ‘waiting for media’ countdown, and then times out.

If someone is willing to try some things out with this DSS, I can
send servers IP offlist.

There’s no special patch, I’ve used jit.qt.broadcast help file, but I
can modify one with the settings i tried, if needed. The suspect is
male, black/asian, some Intel processor, os x 10.4.7, max 4.6, jit
1.6.3b2, armed and dangerous.

cheers,
nesa


March 24, 2007 | 8:05 am

First of all, happy birthday, nesa!

Second of all, yeah, this has been reported before, and there’s just
been no time to figure out what the problem is. Sorry! If it’s any
consolation, it’s one of the first things I’m planning to work on,
when the current wave of responsibilities is exhausted…

jb

Am 24.03.2007 um 04:36 schrieb nesa:

> Hello,
>
> I’m trying to send unicast, video-only stream using
> jit.qt.broadcast from behind a NAT to a Darwin streaming server
> somewhere on the internet, wich should make stream available to
> anyone interested.
> My problem is that I’m the only person on whole internet who can
> receive the stream from darwin streaming server, and that makes my
> non-existant ip one of the loneliest on the planet, please help!
>
> here’s what I’ve tried so far:
>
> i’ve done random tests with h263 and mpeg4 codecs, but latter
> decided to stick to mpeg4 for all programs and try the following :
>
> streaming from apple’s quicktime broadcaster, using automatic
> unicast -> everything ok, lot of people all over the world could
> see the stream;
> streaming from apple’s quicktime broadcaster, using manual unicast
> and manually ulpoaded .sdp file to DSS -> same as above:all ok;
>
> streaming from jitter, jit.qt.broadcast, using unicast and setting
> identical parameters as in apple’s broadcaster, using previous sdp,
> or uploaded one written by jitter->not ok: I was the only one who
> could access the stream. I’ve started Activity Monitor to look at
> network traffic, and it seemed that packets were being sent to
> Darwin Streaming Server, but I’m not 100% sure on this. If open I
> the rtsp://url/sdp from DSS, it seems that there is some incoming
> network traffic, so it seems like the data is travelling from my
> computer to DSS and back to me(the stream stops if I disconnect
> from internet).
> I gave the patch to a friend with PPC, but he had the same results:
> only he could see his stream.
> If someone else opens the stream, Quicktime player would connect,
> but it would do ‘waiting for media’ countdown, and then times out.
>
> If someone is willing to try some things out with this DSS, I can
> send servers IP offlist.
>
> There’s no special patch, I’ve used jit.qt.broadcast help file, but
> I can modify one with the settings i tried, if needed. The suspect
> is male, black/asian, some Intel processor, os x 10.4.7, max 4.6,
> jit 1.6.3b2, armed and dangerous.
>
> cheers,
> nesa
>
>
>



sm
March 24, 2007 | 12:48 pm

hi – i could need some help!

i want to transfer 2d spatial information into 3d gl space.
i other words: i have a face looking into a camera -> treat that
input with jit.op to leaf only the outlines of the face as white
pixels -> this x-y-coordinates of where those pixels should now be
translated into 3d gl space to draw some geometry over the outlines
of the face.

any ideas appreciated!
thanks, michael


October 5, 2007 | 11:55 pm

I have the exact same problem… On some machines the stream comes through fine (even with a very low latency, much lower than a normal Quicktime Broadcaster broadcast on the same streaming server), but on most i just get the waiting for media countdown. My system administrator tells me the packets are being sent to the right place they are just not being picked up.

Did you find a solution to the problem? Any ETA on a fix?

best,
Fenrik

p.s. on a related note, when I use jit.qt.movie to open a stream (i.e. ‘read rtsp://…..sdp’) if the dimensions specified don’t match those of the stream exactly it doesn’t work at all on my mac, and on the pc it works for a while but then it crashes. Setting the dimensions to that of the stream seems to work fine.


Viewing 4 posts - 1 through 4 (of 4 total)