jit.qt.grab: could not create video channel -9405

Aug 6, 2013 at 3:28pm

jit.qt.grab: could not create video channel -9405

Just got a new macbook air, 1.7 GHz Intel Core i7, 8GBs of RAM, running the very latest version of Max, and I can’t get a video channel open with either jit.grab or jit.qt.grab. I’ve tried the bare minimum from the tutorials. I know my built in iSight works, as I can open it with Photo Booth. I coped my whole drive from my Macbook Pro, which worked just fine – and I reinstalled Max just now when it didn’t work, same issue.
Any known problems or patches? Thanks!

PS just tested, and it seems to work in 64-bit mode, but not 32-bit mode – though I prefer 32-bit, so I can still use externals… for now.

#258210
Aug 8, 2013 at 2:49am

A good method (IMHO) to test hardware/MAX connexions is do it via the max helpfiles, e.g. in your case helpfile of jit.qt.grab -> activate the helppatch.
Best
Helmuth

#258304
Aug 8, 2013 at 4:20am

Hi Helmuth,
Thanks, yes, same thing for help patch and tutorials and anything else I’ve tried. The camera works in 64-bit but not 32-bit mode. This is going to prove problematic for all my patches that use externals. Running 10.8.4. Is no one else having this problem on the new Airs?

nathaniel

Attachments:
  1. Screen-Shot-2013-08-08-at-6.17.36-AM
#258312
Aug 10, 2013 at 2:58pm

Bump. Anyone have any clues here? Like I said, the camera works with other apps, and in 64 bit mode, so not sure why nothing is working in 32-bit. Thanks!

#258543
Aug 12, 2013 at 9:22am

Hi Nathaniel,

I’d try restarting, and then trashing Quicktime preferences (which should be in ~/Library/Preferences/).

If you are still having problems, please email support at cycling74 dot com.

Best,
-Ben

#258663
Aug 12, 2013 at 11:03am

Hi Folks,

This is unfortunately a known issue with 32bit Max 6 and the 2013 MacBook Airs – we have an engineering ticket for it.

Sorry for the inconvenience

Cheers

Andrew

#258680
Aug 12, 2013 at 4:19pm

oy. ok. i’ll keep an eye out for a fix. thanks.

#258722
Nov 7, 2013 at 2:06am

any news? i got same problem with new haswell 15″ macbook

#270400
Nov 9, 2013 at 5:17am

Just discovered the same problem:
MacBook Pro 11.3, OS X 10.9 (13A3017)
jit.qt.grab: could not create video channel -9405
jit.qt.grab: error opening device for grab.

News would be good!

#270614
Nov 11, 2013 at 6:16am

I also would love some news about this issue… also because as I read STEFANO test that

“is seems a genera jit.pwindow problem, also with a common qt.movie, the pwindow suck an amazing amount of power specially when more than one. no problem with jit.window
i thought could be a retina screen issue but this does not happen on the first generation retina MBP”

so wandering if is just issue with grab or more a matrix related issue..

#270748
Nov 11, 2013 at 11:05am

News: we can reproduce the -9405-iSight-not-working problem and are preparing a surgical strike.

#270802
Nov 11, 2013 at 11:10am

@martina.menegon your issue sounds like the fact that retina displays require rendering 4x the amount of pixels in the patcher. As mentioned in previous threads and in the advanced scheduler settings vignette of the max documentation, you may wish to “Open in Low Resolution” to reclaim your expected performance.

http://cycling74.com/forums/topic/retina-performance/

MacBook Retina GUI Redrawing Issues

On a Retina Macbook, if you have a patch that is performing a lot of user interface drawing, such as rapid updates to JSUI, you are possibly backlogging the queue, which can have an effect on scheduler performance. On these machines, GUI rendering costs are roughly 4x expensive, unless you disable high resolution support (patchers will look worse). To turn off high resolution support for Max, go to the Finder, and Get-Info (cmd+i) on the Max application icon and check the “Open in Low Resolution” box.

#270804
Nov 12, 2013 at 3:59am

@joshua
my god thanks, was so simple…
i was totally sure it was just a late retina problem, i have a friend with old retina and he don’t have this problem and he probably just forgot to have switched on the low resolution option while we were making the comparison.
the last curious behavior that max still has is with the pays.multiple.mesh patch:
the patch runs 22 fps on old retina, 30 on new retina, 52 on old 2010 13″ MBP,
Don’t know if in this case has sense but i will try a SMC reset as suggested by Karl Kliem in the http://cycling74.com/forums/topic/retina-performance/
thanks everybody for the support

#270939
Nov 16, 2013 at 1:37am

Many Thanks for news of impending iSight strike
& “Open in Low Res” option: I’d been getting low fps (13-15) playing Qts, now it’s up to 30.

#271357
Nov 21, 2013 at 3:03pm

Is there any news on this issue?
Or is anyone aware of a workaround?

I’m on a new Retine Macbook Pro with OSX 10.9, and I also get the following messages:
jit.qt.grab: could not create video channel -9405
jit.qt.grab: error opening device for grab

#272006
Nov 22, 2013 at 3:58am

@KAJDDAVID the only solution so far is opening max in 64, then u can open your grab…
not the best, but is a temporary solution if u need to work :)

#272031
Nov 22, 2013 at 5:16am

Hi Martina – Thanks, I’ve tried that. And then grab works, but the rest of the patch has many errors.
It’s not my patch, so I can’t edit it for 64bit use – I’m doing the live electronics at a concert in a little over a week – looks like it might be a no-live-video-affair, unfortunately…

#272037
Nov 22, 2013 at 5:17am

@Martina – Thanks, I’ve tried that. And then grab works, but the rest of the patch has many errors.
It’s not my patch, so I can’t edit it for 64bit use – I’m doing the live electronics at a concert in a little over a week – looks like it might be a no-live-video-affair, unfortunately…

#272038
Nov 22, 2013 at 6:34am

I have had the -9405 error when using Max6. When reverting to work with Max5 it worked. So if you can get back to Max5 you should be OK.

#272044
Nov 22, 2013 at 7:14am

For me jit.qt.grab cannot access the iSight camera in either Max 5 and 6 (32bit mode)
though I can access DV camera connected through firewire/thunderbolt adapter.
64bit is not a practical option at the moment

MacBook Pro Retina 11.3, OS X 10.9 (13A3017)

#272048
Nov 23, 2013 at 12:52am

Thanks Foxley – I hadn’t tried using an external camera.
It works for me with a USB webcam. Great.

(I can’t get the iSight open in Max 5 or 6)

#273543
Dec 2, 2013 at 6:08am

tried with PS3 eye… no luck
any news?

#274375
Dec 22, 2013 at 3:26am

Thanks for the fix in 6.1.6!
iSight working fine now!

#276411
Dec 22, 2013 at 4:22am

still doesn’t work for me.

#276414
Dec 22, 2013 at 4:55am

Already happened to me occasionally on a non retina mbp with max 6, so there must be something else.

#276419
Dec 22, 2013 at 8:50am

Maybe it’s also Mavericks related. In About this mac > System report > Camera, I still get “There was an error while scanning for video devices”. (It happens with Audio too).

Initially, I thought the iSight problems were related to an app I installed on my iPhone called iWebCamera. The drivers, needed to stream the phone camera output to the MBPro, very aggressively prevented any software from connecting to the built-in iSight on my previous pre-retina MBPro.
I had to remove everything iWebCamera-related to be able to connect to the iSight.

I figured this out after migrating to the new Retina MBPro and was hoping that purging it of IWebCamera stuff would solve the problem, but it didn’t. Hope this is of use.

#276442
Dec 22, 2013 at 9:04am

In my case, it happened with 10.8.

#276443
Dec 23, 2013 at 7:01am

@stephano,

the new version of max uses QTKit, you have to do this to get the ps3eye working (max 32 bits and macam driver):
1. restart Max
2. new patcher
3. new message box with “; jit usealtgrab 0″
4. lock patcher and click message box

see http://cycling74.com/forums/topic/max-6-1-6-released/#post-275650

it works fine for me.

Jean-Michel

#276526

You must be logged in to reply to this topic.