jit.qt.grab quality/codec(?) issue with external DV-equipment

Mar 28, 2013 at 12:46pm

jit.qt.grab quality/codec(?) issue with external DV-equipment

I am experimenting with jit.qt.grab at the moment to build a live video-loop station. An actor should record himself with a Canon XM1 via Composite video and a Canopus ADVC300 digitizer.

When I connect the Canopus (or the Camera via DV, same issue here) and use the video recording function built into QuickTime Player at the maximum quality, I get a DV-coded video at 720×576 which looks pretty good and seems to be the native mode of the digitizer/camera.

If I use the jit.qt.grab object, which should do the same, the quality seems very bad compared to the video recorderd with QuickTime Player, namely i get very pixelated corners and codec-artifacts.

I am in vmode 2 with the jit.qt.grab. The only settings for the codecquality-attribute that seem to work are “minimum”, “normal” and “high”. “Low” looks exactly like “minimum” and “maximum” and “losless” are exactly the same as “high”. Is that normal for some DV-equipment? It doesn’t make a difference if I use the camera directly via DV or if I use the Canopus.

Also the settings-dialog of the jit.qt.grab didn’t help to increase the quality of the output of jit.qt.grab!

Opening a video that was recorded with QuickTime Player and play it back in Jitter looks good, so I suppose it has to do with jit.qt.grab recording and the codec-settings — not with the presentation in jitter. (I thought about a scaling problem when it comes to bring the 720×576 video to the monitor pixel-resolution of 768×576 (4:3) but this isn’t also the point…)

Am I missing something obvious here? I uploaded the basic-patch and two screenshots of the quicktime-recorded output and the jit.qt.grab output in a jit.window

I’m working in Max 6.1.1 on a MacBook Pro (Late 2007) running OS X 10.6.8.

Every help is appreciated! Thanks!

Best,
Jonas

[attachment=219244,5308] [attachment=219244,5309]

Attachments:
  1. QuickTimePlayer.png
#66908
Mar 28, 2013 at 7:35pm

Solved the problem! I accidently found this older forum thread, which told me to turn @singlefield off.

http://cycling74.com/forums/topic.php?id=14230

#240834

You must be logged in to reply to this topic.