jit.qt.grab settings dialog

Sep 30, 2010 at 7:34pm

jit.qt.grab settings dialog

hello list,

i am searching for a method to set parameters
in the video settings dialog of the jit.qt.grab object.
(i am sending a settings message)

i have to adjust the settings manualy every time, i open my patch.
the driver does not remember the changes ….

perhaps someone found a solution for automate this process …

thanks in advance,
j.

#52535
Sep 30, 2010 at 8:09pm

Look at the jit.qt.grab help and reference files. You can do what you need by using attributes in the object.

#188930
Sep 30, 2010 at 8:13pm

Depending on the device, you may also have some luck with setting IIDC features on load. Check out the [iidc_support] subpatcher in the jit.qt.movie help patch.

=Ben

#188931
Sep 30, 2010 at 8:46pm

hello jonathanb and ben,

thank you for your fast response and
helpful information.

the basic parameres are working with simple messages.
saturation, contrast …

these are listed at the tab “adjustments”
in the video settings window. which is similar
to all my input drivers.

but that is not my problem.

i want to disable and adjust the exposure level and time.

these settings are at the special tab in the video settings window,
which only appears, if the device is connected.

with the getiidclist message i only get the printout:
jit.qt.grab: could not get IIDC features

i have tested 2 different usb microscopes.

so there seems to be no IIDC support or this
type of input devices.

perhaps there is a system wide settingsfile or plist,
which i can edit read and write with max.

the last chance is to click and set the sliders
of the settingswindow via applescript.

very nerdy :-)

j.

#188932
Jun 19, 2012 at 10:50am

Hey all,

Just wondering if anyone has found a workaround for this issue yet.

I am in the same situation, I want to set the exposure parameters of the video driver (imagingsource GigE) without manually having to open the video settings every time I restart the patch.

Thanks,
Mattijs

#188933
Jun 19, 2012 at 10:54am
#188934

You must be logged in to reply to this topic.