jit.qt.movie, jit.window and images resolution

Apr 19, 2010 at 2:51pm

jit.qt.movie, jit.window and images resolution

Dear list
i have a problem with resolution of images.

when i load an image (jpg) into jit.qt.movie
and display it via jit.window

the original resolution comes out modified, slightly pixelated, definitely not the original

I can tell this because if I display the same image with keynote or preview (on a mac) the image looks totally fine

i used interpolation and some settings of the frame size
but this still does not display the right original resolution

is there something I am missing ?
i’ve been through docs and forum and found that it should be something
related to the size difference between jit.qtmovie and jit.window. bur im not sure.

this happens more likely with images
, not with videos (or not that I am aware of).

any help would greatly appreciated

thank you in advance

tom

#49861
Apr 19, 2010 at 7:43pm

Hi Tom,

If you have an image and a very simple patch and an image that exhibits the problem, send it along. OS, computer model and version of Max too.

-Ben

#179063
Apr 19, 2010 at 11:10pm

thanx for answering Ben,
here’s the patch

– Pasted Max Patch, click to expand. –
#179064
Apr 19, 2010 at 11:11pm

this is th eimage I have problems with

[attachment=130392,409]

Attachments:
  1. 04-PP7-Singularity.jpg
#179065
Apr 19, 2010 at 11:14pm

As you can see it is a very low quality image.
Yet when it is displayed by Keynote, Powerpoint or any preview it has the aspect you can see.

When I am displaying via jitter, with the above patch , it does this:

[attachment=130394,410]

Attachments:
  1. resbad.tiff
#179066
Apr 19, 2010 at 11:16pm

my computer is a intel macbook

Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 2 GB
Bus Speed: 667 MHz

with graphic card:

Chipset Model: GMA 950
Type: Display
Bus: Built-In
VRAM (Total): 64 MB of Shared System Memory

Yet, even with the same type of computer, but 2 years younger (so with an updated graphic card)
the results are the same.

thanx a lot in advance if you can help

tom

#179067
Apr 19, 2010 at 11:42pm

unless your jit.window has the same dimensions as your source material, there will be distortion of the image.

see if this snippet helps at all. it basically utilizes @adapt 1 in jit.qt.movie to keep the dimensions of the source file, and set the @size attribute of the jit.window.

– Pasted Max Patch, click to expand. –
#179068
Apr 20, 2010 at 7:41am

it looks it works extraordinarily perfect
thank you robtheric
thank you all guys

#179070
Apr 20, 2010 at 8:18am

observation:
I have noticed that using this snippet, it will modify the full screen option I gave for displaying jit.window, and obviously the reason is that the snippet resizes the window’s dimensions.

Basically now I know the reason why of the resolution problems, and how the snippets solves it.

Yet I noticed that :
if I set the jit.window settings to the size of the screen/projector it is going to be displayed ,
using @adapt 1 on jit.qt.movie, it does the trick without having to resize the jit.window every time we load a movie.

thankx a lot
this list is the best

#179071
Jun 24, 2013 at 12:46pm

hi, i am having issues with this as well. I am trying to display an image which is 1366 x 768 but when i full screen, the image ever so slightly distorts. How can i get it not too when on full screen. I have @adapt 1 on the jit.qt.movie object. here is a test patch.

any help much appreciated!

<code>

– Pasted Max Patch, click to expand. –

</code>

Attachments:
  1. 1
#253904
Jun 24, 2013 at 2:00pm

easiest way is to use opengl, and the jit.gl.cornerpin object with @preserve_aspect 1

– Pasted Max Patch, click to expand. –
#253915
Jun 24, 2013 at 2:33pm

Rob Ramirez, thankyou so much.

i think this will definitely work!

i was going round in circles with this, and had found a hack way around the issue (which was actually being caused by the @noaccel 1 attribute.

On my apple machine i didn’t need it, but the exhibition was on a windows machine. The attribute was on the patch, and thus causing issues, as i was editing the patch on my own machine. On the windows machine it works fine with the @interp 1 attribute. However your way is much better ad looks much neater with the full border….

thankyou so much again!

#253922

You must be logged in to reply to this topic.