Forums > MaxMSP

jit.uldl troubles with authentication


f.e
February 6, 2009 | 5:43 pm

Hello,

I’m trying to use jit.uldl to retrieve .xml files from
http://www.pachube.com/ and i got problems with the authentication key.
The correct syntax is :
|http://pachube.com/api/494.xml?key=ENTER_YOUR_PACHUBE_KEY_HERE|
and it works well when typed in Firefox, but doesn’t when i use a Max
message [download http://www.pachube.com/api/494.xml?key=my-key-here to
the jit.uldl box.

The server returns : Couldn’t authenticate
you

And the Max Window :

print: defaultdir C:/MaxMSP5/fe – all/fe – patches/ideas &
experiments/weather
print: dl_status 60
print: dl_status 320
print: dl_status 10
print: dl_status 11
print: dl_status 20
print: dl_status 21
print: dl_status 30
print: dl_status 31
print: dl_status 40
print: dl_status 41
print: dl_status 100
jit.uldl: could not create file
print: dl_status 40
print: dl_status 41
print: download 0

What’s wrong ?

f.e


f.e chanfrault | aka | personal computer music
> >>>>>> http://www.personal-computer-music.com
> >>>>>> | film soundtracks, sound art, music |



f.e
February 8, 2009 | 10:30 am



f.e
February 9, 2009 | 10:25 am


February 9, 2009 | 5:03 pm

Try putting "matrix" on the end of you "download" message and hook your [jit.uldl] up to a [jit.textfile]. This works fine for me.

lh

– Pasted Max Patch, click to expand. –


f.e
February 11, 2009 | 9:41 am


February 11, 2009 | 11:31 am

Perhaps post the original patch you had and I’ll have a look. How is the weather in Moscow today? =)

lh



f.e
February 11, 2009 | 4:35 pm


February 11, 2009 | 6:59 pm

That’s odd, it works for me. Here’s a very similar patch I’ve thrown together which works perfectly, let me know if it gives you problems. The other patch on the right shows you a way to grab the xml file details. Remember to hit the [loadmess]es once you’ve opened the file. I hope it helps.

lh

– Pasted Max Patch, click to expand. –


f.e
February 11, 2009 | 7:12 pm


February 11, 2009 | 7:27 pm

So it doesn’t create the file at all? That is odd. Maybe it is some sort of problem with the windows version of the object? I wonder if anyone else can chip in and try out one of these patches and leave feedback. I’m on OSX 10.4.11 and Max 5.0.4 and no problems here. The curious thing is that the "matrix" version stored in [jit.textfile] does work for you. Have you tried saving the file to disc directly from the [jit.textfile] using "write" and then loading it into your [coll]?

lh


February 11, 2009 | 7:32 pm


February 11, 2009 | 7:48 pm

> probably if you would try with escapes? "C:/MaxMSP5/fe – all/fe -
> patches/ideas & experiments/weather/494.xml"
> there are spaces in the pathname.

Or just get rid of the spaces in the path. That’s the first thing I
would try. Spaces always cause problems… I’ve learned to hate that
freaking "Program Files" folder.

Adam



f.e
February 12, 2009 | 11:48 am

No no no, i’ve been through that, the path syntax is correct, and it
doesn’t even work with c:/temp path, imagine the nightmare.

@Luke : it works fine with jit.textfile, i can write to disk than read
with toxine…

f.e

f.e chanfrault | aka | personal computer music
> >>>>>> http://www.personal-computer-music.com
> >>>>>> | film soundtracks, sound art, music |

Adam Murray a écrit :
>> probably if you would try with escapes? "C:/MaxMSP5/fe – all/fe -
>> patches/ideas & experiments/weather/494.xml"
>> there are spaces in the pathname.
>>
>
> Or just get rid of the spaces in the path. That’s the first thing I
> would try. Spaces always cause problems… I’ve learned to hate that
> freaking "Program Files" folder.
>
> Adam
>
>


Viewing 13 posts - 1 through 13 (of 13 total)