Forums > Jitter

jit.window flushlimit ?

May 30, 2007 | 6:25 pm

Is undocumented. defaults to 25? What does this do?

v a d e //

http://www.vade.info
abstrakt.vade.info


May 30, 2007 | 7:33 pm

On May 30, 2007, at 11:25 AM, vade wrote:

> Is undocumented. defaults to 25? What does this do?

You mean jit.pwindow, I presume. It is how often jit.pwindow requests
the backing window to force a screen update. Probably not necessary
to tweak unless you think that the window is not updating fast or
slow enough. Kind of like a speedlim on actually flushing the window
contents.

-Joshua


May 30, 2007 | 7:42 pm

Nope, I ran across this when trying to debug a VBL sync issue with
1.6.3 final which I just posted to the list, with jit.window, not
pwindow. I found it by doing the apple+option and clicking on an
object to see the attribute state

Thanks for the clarification.

On May 30, 2007, at 3:33 PM, Joshua Kit Clayton wrote:

>
> On May 30, 2007, at 11:25 AM, vade wrote:
>
>> Is undocumented. defaults to 25? What does this do?
>
> You mean jit.pwindow, I presume. It is how often jit.pwindow
> requests the backing window to force a screen update. Probably not
> necessary to tweak unless you think that the window is not updating
> fast or slow enough. Kind of like a speedlim on actually flushing
> the window contents.
>

v a d e //

http://www.vade.info
abstrakt.vade.info


May 30, 2007 | 9:00 pm

On May 30, 2007, at 12:42 PM, vade wrote:

> Nope, I ran across this when trying to debug a VBL sync issue with
> 1.6.3 final which I just posted to the list, with jit.window, not
> pwindow. I found it by doing the apple+option and clicking on an
> object to see the attribute state
>
> Thanks for the clarification.

Oh, that’s for the @noaccel 1 mode, and probably safe to ignore.

-Joshua


May 30, 2007 | 9:29 pm

Hello

I am using Jitter 1.5 on a G4 powerbook with OSX 10.3.9. Quite often I
create video samples [320x240] movies for mixing and other VJ
shenanigans. When I bring the windo to my second monitor and fullscreen
the window the movie looks like for the lack of a better term "like
dogmeat". Whilst other programs I have used **cough** GEM seems to blow
the file up without pixelating the movie. Are there anytips one may use
to lessen this obvious problem, save for making the original clips
themselves larger?

Cheers and thanks

Pat


May 30, 2007 | 9:35 pm

How exactly are you showing the video? Have you tried using a
videoplane object? Basically you want interpolated textures.

wes

On 5/30/07, Pagano, Patrick

wrote:
> Hello
>
> I am using Jitter 1.5 on a G4 powerbook with OSX 10.3.9. Quite often I
> create video samples [320x240] movies for mixing and other VJ
> shenanigans. When I bring the windo to my second monitor and fullscreen
> the window the movie looks like for the lack of a better term "like
> dogmeat". Whilst other programs I have used **cough** GEM seems to blow
> the file up without pixelating the movie. Are there anytips one may use
> to lessen this obvious problem, save for making the original clips
> themselves larger?
>
> Cheers and thanks
>
> Pat
>
>


May 30, 2007 | 9:48 pm

On May 30, 2007, at 2:33 PM, Pagano, Patrick wrote:

> I am using Jitter 1.5 on a G4 powerbook with OSX 10.3.9. Quite often I
> create video samples [320x240] movies for mixing and other VJ
> shenanigans. When I bring the windo to my second monitor and
> fullscreen
> the window the movie looks like for the lack of a better term "like
> dogmeat". Whilst other programs I have used **cough** GEM seems to
> blow
> the file up without pixelating the movie. Are there anytips one may
> use
> to lessen this obvious problem, save for making the original clips
> themselves larger?

jit.window @interp 1

-Joshua


May 30, 2007 | 9:53 pm

jit.window @interp 1?

GEM and Jitter should display exactly the same. And actually, in my
tests if using YUV textures and jitters YUV to RGBA shader conversion
with chroma filtering it looks better than GEMs output.

But you have to do some work to set it up with openGL and Wes pointed
out.

On May 30, 2007, at 5:35 PM, Wesley Smith wrote:

> How exactly are you showing the video? Have you tried using a
> videoplane object? Basically you want interpolated textures.
>
> wes
>
> On 5/30/07, Pagano, Patrick

wrote:
>> Hello
>>
>> I am using Jitter 1.5 on a G4 powerbook with OSX 10.3.9. Quite
>> often I
>> create video samples [320x240] movies for mixing and other VJ
>> shenanigans. When I bring the windo to my second monitor and
>> fullscreen
>> the window the movie looks like for the lack of a better term "like
>> dogmeat". Whilst other programs I have used **cough** GEM seems to
>> blow
>> the file up without pixelating the movie. Are there anytips one
>> may use
>> to lessen this obvious problem, save for making the original clips
>> themselves larger?
>>
>> Cheers and thanks
>>
>> Pat
>>
>>

v a d e //

http://www.vade.info
abstrakt.vade.info


May 31, 2007 | 2:38 pm

Thanks everyone! I had a feeling but did not know exactly how to ask it
for jitter
I spit the second screen out to a proxima 4500 and I was initially
shocked at the difference
I usually just record movies to 320×240 so it had never been an issue
until recently

Thanks

Pat

—–Original Message—–
From: jitter-bounces@cycling74.com [mailto:jitter-bounces@cycling74.com]
On Behalf Of Wesley Smith
Sent: Wednesday, May 30, 2007 5:36 PM
Subject: Re: [jitter] Jit.window question

How exactly are you showing the video? Have you tried using a
videoplane object? Basically you want interpolated textures.

wes

On 5/30/07, Pagano, Patrick

wrote:
> Hello
>
> I am using Jitter 1.5 on a G4 powerbook with OSX 10.3.9. Quite often I

> create video samples [320x240] movies for mixing and other VJ
> shenanigans. When I bring the windo to my second monitor and
> fullscreen the window the movie looks like for the lack of a better
> term "like dogmeat". Whilst other programs I have used **cough** GEM
> seems to blow the file up without pixelating the movie. Are there
> anytips one may use to lessen this obvious problem, save for making
> the original clips themselves larger?
>
> Cheers and thanks
>
> Pat
>
>


August 14, 2007 | 4:23 pm

I am curious about this, as I noticed setting it to "100" for four 80×60 pwindows actually reduced cpu use (as reported by Activity monitor) considerably. In this case, the cpu usage went from 50% to 38% simply by changing the flushlimit from 0 to 100. However, my fps went from 60 to 28! All very bizzare. Perhaps ignorance IS bliss…


Viewing 10 posts - 1 through 10 (of 10 total)