jit.window inverted image bands problem

Mar 10, 2009 at 6:45pm

jit.window inverted image bands problem

Hi

I’m having a problem using jit.window in fullscreen mode when my display resolution is set to 1920×1080.

The video gets chopped into 32 horizontal slices that are displayed from bottom to top, making the image look inverted. Although each slice displays video right side up.

I’m using Max 5.0.6, Windows XP Home and an integrated ATI Radeon HD 3200 GPU with an HDMI connection to a BenQ E2200HD LCD monitor.

The problem happens when the input to the jit.window is a (jit.qt.movie 1920 1080) or a (jit.qt.grab 1920 1080) and the jit.window is in full screen with a display resolution of 1920×1080. I have also been able to recreate the problem by reading a 1920×1080 video with a (jit.qt.movie 480 320) not in full screen, although in that case there were only 2 and a half horizontal bands.

I would be very grateful if anyone could reproduce this problem or find a solution to it!

Thank you

Frederic

#42773
Mar 10, 2009 at 7:58pm

best way for us to reproduce is to send us a stripped down patch which demonstrates the problem. paste it into the forum using Edit->Copy Compressed.

-rob

#153132
Mar 10, 2009 at 9:16pm

– Pasted Max Patch, click to expand. –
#153133
Mar 16, 2009 at 4:44pm

Has no one experienced or been able to reproduce this?

#153134
Mar 16, 2009 at 6:56pm

I can’t reproduce here, but it sounds like it is a driver, rather than a Jitter issue, since it doesn’t happen on other HW combinations. First thing I would suggest is to update your drivers and see if it persists. Here’s the link to the latest official ATI driver for your setup (XP Home Catalyst 9.2 driver)

http://support.amd.com/us/gpudownload/windows/Pages/integrated_mce-xp.aspx?type=2.7&product=2.7.4.3.3.3.1&lang=English

-Joshua

#153135
Mar 17, 2009 at 1:26am

Hi, thanks for your help. I’ve updated the drivers but the problem still persists. Are there any settings in the display driver control panel, or in Max that could be changed to solve the problem, or any other ideas?

Thank you

#153136
Mar 21, 2009 at 4:24am

Actually, after some testing, it seems that the issue I am experiencing is much more general than the situation I described in my first post. Whenever a jit.window’s height is equal to the height of it’s input, the image is chopped into bands…

While writing this I have done more investigating and it seems the problem only occurs when the interp flag is set to 0, which is the default. Setting the flag to 1 seems to solve the problem for now.

I would be interested in an explanation to this strange behavior, if anyone has one.

Thank you

#153137
Mar 22, 2009 at 3:21am

Does it look somewhat like the picture here:

http://www.villamil.org/images/ATI%20-%201%20-%20basic.jpg

I have also experienced a multi-banding problem when working in very high resolution screen modes.

#153138

You must be logged in to reply to this topic.