jit.window unuseable without interp? on XP

Feb 11, 2006 at 11:25pm

jit.window unuseable without interp? on XP

Somewhere in the last few Jitter updates there was a major behavioral change with jit.window and the interp attribute. My initial experience was that “interp 0″ was the default and that enabling “interp 1″ resulted in a slight slowing of the framerate, and a smooth interpolation of the matrix to window size. The next version changed the behavior to where there was little framerate difference between interp 0 or 1, but the same difference between interpolated and non-interpolated output. NOW, with interpolation disabled, the framerate is unuseably slow. As an example, Andrews recent 2d version of his swirl patch does not have interp enabled by default. When I initially loaded his patch, it started up at a nearly system disabling 1.036 FPS. Enabling interpolation makes the radical jump up to a stable 23FPS.
So, as it stands, it seems as if something needs to be done to allow “interp 0″ to not tank the system. In the past, I’ve actually preferred the craggy/sharp look of uninterpolated output when the results are going to be fed analog to a projector, losing sharpness in the process. It also occurs to me that by having interpolation defaulted as disabled, new users will be greeted with system slamming poor performance as their default. Increasing framerate by enabling interpolation is counterintuitive; a bit of arcane magic that new users need to be informed of in the documentation, or shielded from by a defaulting the enabled state.

OR
Is my graphics card/particular setup/XP somehow wonky, making this whole thing a personal problem?

Latest Max/Jitter Graphics card drivers.
Windows XP
The example patch of Andrew’s is a prime example

#24388
Feb 12, 2006 at 1:20am

If you give me a url for the patch that’s causing problems or email me a copy offline, I’ll try it out on my XP machine.

Interpolation causes no problems either on or off, either on or off. But I don’t use OpenGL.

Adam

#70442
Feb 12, 2006 at 1:52am

http://www.cycling74.com/forums/index.php?t=msg&th=18217 &start=0&rid=3166&S=1bf6f792079851e4dac7626aacbd ba71

The “VideoSynth3″ is an example.

Without an “@interp 1″ on jit.window soft I get 1.032 FPS. Once I add “@interp 1,” I get 23FPS.

#70443
Feb 12, 2006 at 2:46am

On Feb 11, 2006, at 3:25 PM, Leo Mayberry wrote:

>
> Somewhere in the last few Jitter updates there was a major
> behavioral change with jit.window and the interp attribute. My
> initial experience was that “interp 0″ was the default and that
> enabling “interp 1″ resulted in a slight slowing of the framerate,
> and a smooth interpolation of the matrix to window size. The next
> version changed the behavior to where there was little framerate
> difference between interp 0 or 1, but the same difference between
> interpolated and non-interpolated output.

This should typically be the case, still with the current version,
however, it sounds like for some reason glDrawPixels is slower than
using a texture on your machine. You can use a texture without
interpolation by setting @mode texture, with @interp 0 (the default).
By default, @mode is auto, which uses @mode drawpixels for standard
usage, and @mode texture for @interp 1 or @colormode uyvy. You can
also try using @mode noaccel, which will bypass OpenGL entirely for
drawing to the window.

> OR
> Is my graphics card/particular setup/XP somehow wonky, making this
> whole thing a personal problem?

Sounds like something might be up with your graphics driver, as
typically, glDrawPixels is not that much slower than texture submission.

-Joshua

#70444
Feb 12, 2006 at 7:05pm

I get approx. 38/39 fps with interp on or off.

xp sp1
p4 3.2Ghz
ATI Radeon 9700
Latest Max/MSP/Jitter release
Didn’t see what my audio settings were

Adam

#70445
Feb 12, 2006 at 10:48pm

Hmm…

Adam, it sounds like you have a very similar setup to mine.
I’m running a Dell Inspiron 9100
with an ATI 9700.
What drivers are you using?
Any particular settings tweaks?

#70446
Feb 13, 2006 at 4:23am

Yeah, I have a 9100.

Doing nothing special on it. Drivers are dated Aug. 17, 2004.

Have you gone through the advanced options under the settings tab? There are some OpenGL options. I keep mine in default.

Adam

Quote: jitter@killingfrenzy.com wrote on Sun, 12 February 2006 15:48
—————————————————-
> Hmm…
>
> Adam, it sounds like you have a very similar setup to mine.
> I’m running a Dell Inspiron 9100
> with an ATI 9700.
> What drivers are you using?
> Any particular settings tweaks?
—————————————————-

#70447
Feb 13, 2006 at 9:00am

Hmm…
Defaulting the setting didn’t help.
BUT
Reinstalling the drivers did.
Now it doesn’t make a noticeable difference.

Good to know the various options, Joshua, as these will help me in the future.

Thanks all round for sorting out my issue.

#70448

You must be logged in to reply to this topic.