"jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration" issue

Jan 21, 2010 at 4:33pm

"jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration" issue

Hello all!

I opened the patch springoidgrid3d-example2 from the JavaScript examples.
The patch starts normally, but I notice a strange flickering in the background, and the max window displays a message like:

jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration

I have 2 machines, a mac book pro, that does not present the above problem,
and a pc that does, with specs:
AMD Phenom(QuadCore) @ 3.5 or so,
4 gb RAM
ATI Radeon HD 4890 with 2 GB mem.
Windows 7 (64bit)

Might I add that the drivers for the GPU are up to date.
Is there something I should be doing concerning settings to fix the issue?
Or is it something else?

#47930
Jan 21, 2010 at 7:25pm

I doubt that the message about float pixels is related. Your card should support floating point pixel formats, however. Hrmmm.

The flickering might just be the way that buffering is being done on your card. Sometimes this is also settable in the OpenGL control panel for your graphics driver. The big thing about this example is that it uses an erase color with a zero alpha component. This might not work out on your system with your graphics card the way we are using it.

If you need this kind of trails like behavior, here’s what I would start playing with:

1. check out your driver settings and play with anything related to “double-buffering” or other advanced settings like multi-gpu capabilities, etc.
2. try changing the patch to have an erase_color with an alpha of 1.0, and don’t trigger an erase with each swap. Like the following patch.

Let us know if you find something out, since this is pretty difficult for us to investigate without a similar HW/SW setup.

Thanks,
Joshua

– Pasted Max Patch, click to expand. –
#172368
Jan 22, 2010 at 12:34am

@Joshua: thank you for the advice!

Since other people in the future might have the same issues, involving
a similar setup, I will outline the steps I took to get rid of the flickering:

  1. I followed you cue, and enabled a “triple buffering option” in the settings
  2. I changed the general Graphics settings to “Optimal Quality” (via Catalyst Control center) and finally,
  3. I put the [qmetro] in a range of 10 – 8 ms, and then it got really smooth! (fps overkill? well no sweat for my setup :) )

I still get that GL float pix message, but I figure, as long as it does not break anything, it is fine by me!

Thanks again!
Panos

#172369

You must be logged in to reply to this topic.