Jit_matrix error

May 23, 2008 at 5:30pm

Jit_matrix error

Could you please tell me what is this error about?
Jit_matrix : bad number
I keep receiving this error through my Max window.
Thank you for your help and please tell me how I can fix this. Great thanks!!!

#38026
May 23, 2008 at 7:31pm

Please post a patch. Are you using jit.expr?

wes

On Fri, May 23, 2008 at 10:30 AM, Emerald wrote:
>
> Could you please tell me what is this error about?
> Jit_matrix : bad number
> I keep receiving this error through my Max window.
> Thank you for your help and please tell me how I can fix this. Great thanks!!!
>

#131763
May 23, 2008 at 8:41pm

Here is my patch

max v2;
#N vpatcher 42 59 1137 827;
#P origin 0 -10;
#P window setfont “Fixedwidth Serif” 10.;
#P window linecount 1;
#P message 67 463 41 1441802 start;
#P message 68 439 32 1441802 stop;
#P button 45 393 15 0;
#P user jit.pwindow 65 536 161 122 0 1 0 0 1 0;
#P window setfont “Sans Serif” 9.;
#P newex 67 489 52 196617 metro 40;
#P newex 131 460 48 196617 loadbang;
#P newex 65 736 90 196617 jit.chromakey;
#P newex 68 511 111 196617 jit.qt.movie 1024 768;
#P message 131 491 97 196617 read candyBar.mov;
#P window setfont “Fixedwidth Serif” 10.;
#P newex 67 685 92 1441802 vexpr $i1/255.;
#P newex 67 709 83 1441802 prepend color;
#P newex 67 662 62 1441802 prepend 0;
#P window setfont “Sans Serif” 9.;
#P newex 83 42 59 196617 t gettime b;
#P window setfont “Fixedwidth Serif” 10.;
#P newex 157 76 53 1441802 loadbang;
#P user jit.pwindow 133 173 197 148 0 1 0 0 1 0;
#P message 130 114 112 1441802 read gamePlay.jpg;
#P toggle 82 -14 15 0;
#P newex 83 9 58 1441802 metro 40;
#P newex 110 144 136 1441802 jit.qt.movie 1024 768;
#P connect 8 0 12 0;
#P fasten 11 0 12 0 53 530 53 734 70 734;
#P connect 11 0 15 0;
#P fasten 16 0 14 0 50 485 72 485;
#P connect 15 0 7 0;
#P connect 7 0 9 0;
#P connect 9 0 8 0;
#P connect 14 0 11 0;
#P fasten 17 0 11 0 56 455 56 507 73 507;
#P fasten 18 0 11 0 56 479 56 508 73 508;
#P connect 10 0 11 0;
#P connect 2 0 1 0;
#P connect 1 0 6 0;
#P fasten 1 0 0 0 55 27 55 145;
#P connect 3 0 0 0;
#P fasten 6 0 0 0 88 77 115 77;
#P fasten 6 1 0 0 137 77 115 77;
#P fasten 2 0 3 0 149 1 149 93 135 93;
#P connect 5 0 3 0;
#P connect 13 0 10 0;
#P fasten 0 0 4 0 115 169 139 169;
#P fasten 0 0 12 1 115 202 32 202 32 732 150 732;
#P pop;

Thank you!

#131764
May 23, 2008 at 8:54pm

you’re sending a jit_matrix message to the prepend 0 and it’s giving
you the error somewhere after that because the jit_matrix thing isn’t
a number.
wes

On Fri, May 23, 2008 at 1:41 PM, Emerald wrote:
>
> Here is my patch
>
>
> max v2;
> #N vpatcher 42 59 1137 827;
> #P origin 0 -10;
> #P window setfont “Fixedwidth Serif” 10.;
> #P window linecount 1;
> #P message 67 463 41 1441802 start;
> #P message 68 439 32 1441802 stop;
> #P button 45 393 15 0;
> #P user jit.pwindow 65 536 161 122 0 1 0 0 1 0;
> #P window setfont “Sans Serif” 9.;
> #P newex 67 489 52 196617 metro 40;
> #P newex 131 460 48 196617 loadbang;
> #P newex 65 736 90 196617 jit.chromakey;
> #P newex 68 511 111 196617 jit.qt.movie 1024 768;
> #P message 131 491 97 196617 read candyBar.mov;
> #P window setfont “Fixedwidth Serif” 10.;
> #P newex 67 685 92 1441802 vexpr $i1/255.;
> #P newex 67 709 83 1441802 prepend color;
> #P newex 67 662 62 1441802 prepend 0;
> #P window setfont “Sans Serif” 9.;
> #P newex 83 42 59 196617 t gettime b;
> #P window setfont “Fixedwidth Serif” 10.;
> #P newex 157 76 53 1441802 loadbang;
> #P user jit.pwindow 133 173 197 148 0 1 0 0 1 0;
> #P message 130 114 112 1441802 read gamePlay.jpg;
> #P toggle 82 -14 15 0;
> #P newex 83 9 58 1441802 metro 40;
> #P newex 110 144 136 1441802 jit.qt.movie 1024 768;
> #P connect 8 0 12 0;
> #P fasten 11 0 12 0 53 530 53 734 70 734;
> #P connect 11 0 15 0;
> #P fasten 16 0 14 0 50 485 72 485;
> #P connect 15 0 7 0;
> #P connect 7 0 9 0;
> #P connect 9 0 8 0;
> #P connect 14 0 11 0;
> #P fasten 17 0 11 0 56 455 56 507 73 507;
> #P fasten 18 0 11 0 56 479 56 508 73 508;
> #P connect 10 0 11 0;
> #P connect 2 0 1 0;
> #P connect 1 0 6 0;
> #P fasten 1 0 0 0 55 27 55 145;
> #P connect 3 0 0 0;
> #P fasten 6 0 0 0 88 77 115 77;
> #P fasten 6 1 0 0 137 77 115 77;
> #P fasten 2 0 3 0 149 1 149 93 135 93;
> #P connect 5 0 3 0;
> #P connect 13 0 10 0;
> #P fasten 0 0 4 0 115 169 139 169;
> #P fasten 0 0 12 1 115 202 32 202 32 732 150 732;
> #P pop;
>
> Thank you!
>

#131765
May 24, 2008 at 5:31am

So now how can I fix this? Thank you so much!!!

#131766
May 24, 2008 at 6:21am

removing the matrix connection from the prepend 0 would be a start.

it looks like you’re trying to do some chromakeying. you probably need to look at the suckah object, and the chromakey help file, and the related jitter tutorial.

#131767
May 24, 2008 at 6:38am

Ok. Thanks a lot!!!

#131768

You must be logged in to reply to this topic.