Forums > Max For Live

jitter and audio with max for live

December 9, 2010 | 12:09 am

When I use my camera in a jitter project live (filming me live), my sound glitch sometime like a cd skipping or a vinyl crackling…. But my cpu is not too high like 14-15 %….How I can avoid that ? Is there a trick I can do or it’s normal….

Thanx in advance Ben


December 9, 2010 | 11:00 am

Hi Benoit,

CPU meters are not always accurate, they are more like a VU meter than a peak meter
So I guess Jitter is asking too much sometimes
Maybe there is some optimization to do in your patcher or some changes in Max audio preferences ( buffer settings)

you can post an example here so we could test it

olivier


December 10, 2010 | 1:28 am

You might want to make sure that you use qmetro, and not metro. A Max for Live device uses always scheduler in audio interrupt which is great for tight even precision, but that’s not what you want to use for triggering video.


December 10, 2010 | 9:05 am

hm,
Interesting.
thanks Emmanuel.

Is it still true when we edit a m4l device ?

olivier


December 14, 2010 | 3:24 pm

Yes it is. You can see overdrive is disabled in the options menu.


December 14, 2010 | 4:47 pm

ha ! , you mean Overdrive

that’s not exactly how I understand Overdrive from the manual

I don’t want to sound ironic Emmanuel, I am just curious.

http://cycling74.com/docs/max5/vignettes/core/scheduler_preferences.html

"Overdrive
When Overdrive is enabled, Max gives priority to timing and MIDI processing over screen drawing and user interface tasks such as responding to mouse clicks. As a general rule: if you are primarily going to be using Max for MIDI or audio processing, Overdrive should be enabled. If you are primarily going to be using Jitter, Overdrive should be disabled. In addition, the debugging features of Max only work if overdrive is disabled."


December 15, 2010 | 8:19 pm

When overdrive and scheduler in audio interrupt are on, which is the case in Max for Live, it allows you to have really tight precision for playing notes and event in general. When you’re playing with video, you don’t really care about time precision the same way (if a frame arrive a couple of ms later that’s not an issue, cos’ your eyes probably won’t see the difference ). That’s why you should always use qmetro for playing video, it does play the video with a lower priority, maintaining the precise timing for the events that need to be in sync.

On the subject, Joshua’s article is worth to look at.


December 17, 2010 | 10:50 am

"scheduler in audio interrupt"

I knew about overdrive but not about this last one,

now it makes sense.

Thanks Emmanuel

olivier


December 23, 2010 | 8:31 am

Thanx a lot…Merci beaucoup…When I have put overdrive off (I hope) my problem was resolve….

Thanx a lot an merry christmas from Québec !!!!!


December 23, 2010 | 2:09 pm

:-)


Viewing 10 posts - 1 through 10 (of 10 total)