Jitter video efficiency issues

Sep 23, 2010 at 8:13pm

Jitter video efficiency issues

Hello,

Is there somewhere on this forum a tutorial or some advises for video efficiency : ie How to have fluid, smooth and large video with jitter.

I tried many times to do some simple video actions either with jit.qt.movies or camera input but the video is always slows down, blocks and sometimes freezes the hole application.
This happens even with a very powerfull machine, with quite small images (800/6000). For example on a mac pro 8 dual proc the processors are nearly not active and the video plays like a slug.

How come ?
There must be ways to work with good size and fluid video !

Thanks a lot
Rolnad Cahen

#52447
Sep 23, 2010 at 8:44pm

I think Vade (maybe?) did a series of patches on optimising QT playback, have a search. But I’m sure posting a problem patch would get you some good tips.

For reference, I play background QT movies encoded as PhotoJPG at a res of 2400×600 with GL stuff or smaller movies with an alpha channel (Animation codec) over the top and as long as I patch carefully it all runs smoothly (mostly!).

#188614
Sep 24, 2010 at 10:10am

here is the link to Vade´s optimization tutorials.

http://abstrakt.vade.info/?p=147

enjoy!

#188615
Oct 6, 2010 at 12:53pm

A video tutorial about that would be great! And I would like to find something about the overall way jitter works,
the diferences between jit objects that operate on cpu and those jit.gl objects that operate on gpu, and how these comunicate between them, by sharing names, etc. These are not very clear to me, because sometimes I think I’m doing things right and then it doesn’t work.
best to all

#188616

You must be logged in to reply to this topic.