Forums > MaxMSP

jsui error -1409 in application

February 14, 2009 | 6:59 pm

Hi folks,

I’m building a standalone application that uses jsui to control a knob. I’ve included both the knob image (knobmaster.pct) and the javascript file in the build script, but when I open the created application, there is an empty box where the knob should be. If I click and drag in the empty box, I get the kinds of data readout I should, I just don’t get the image of the knob. In the max window for the built application, I have the following line:

sketch_image: knobmaster.pct error -1409 opening file

Can someone point me to what I’m doing wrong? It works as expected in the maxpatch, just not the app build. Thanks so much!


February 14, 2009 | 10:35 pm

Never mind, I realized I needed the absolute path to the image file in the js file.


February 14, 2009 | 11:26 pm

Oops, looks like I spoke (typed) too soon. I am trying to use the jsui object to create a knob that uses an image file in a standalone application. I can get it to work on the computer I build the app on, but not when I port it to another machine. Obviously, I’m not referencing the image properly, but I’m confused about how to reference the image for the standalone.

1. Do I use the absolute path to the image in the js file?
2. Do I need to include both the image and the js file in the build script, or will they be added automatically as a result of the jsui being in the maxpatch?

Thanks for any and all help.


Viewing 3 posts - 1 through 3 (of 3 total)