Just hit a small hurdle in my first max patch

Nov 14, 2013 at 11:02am

Just hit a small hurdle in my first max patch

The problem is that the number box isn’t refreshing when the switch changes. The number only seems to change when I’m moving a dial, not when opening and closing different inlets.

Is there a way to make the number object ‘refresh’ or for the dials to resend their output when bangs from the sel objects come in?

Or maybe I’m coming at this from the wrong angle?

#271237
Nov 14, 2013 at 1:11pm

It would be easier to help if you pasted your patch into a forum post. See:

http://cycling74.com/forums/topic/how-to-post-patches-to-the-forum/

#271251
Nov 14, 2013 at 1:23pm

Yeah I realise now, no problem anyway I’ve sorted it.

Changed the number objects to messages and now I can bang out the message in sync with the metro :-)

#271253
Nov 15, 2013 at 3:59am

You shouldn’t have to use a metro to bang a message to make simple numerical processes occur. With big patches this can become very inefficient.
If your using gswitch then this makes sense as it only routes data, it doesn’t output a number when the switch changes. Theres probably a more efficient way to do this.
Try uploading a patch and see if someone can help you out :)

#271309
Nov 15, 2013 at 5:22am

And don’t crosspost to the reddit too – you’re always going to end up wasting the time of one of the groups that way… :(

#271312
Nov 15, 2013 at 5:25am

I actually thought my post here had failed to upload, note that there is no attachement.

I was stuck on ‘waiting for cycling74.com’ and then ended up receiving some replies by email to my surprise.

#271313

You must be logged in to reply to this topic.