Jweb hiding problem when is inside a bpatcher

Nov 24, 2010 at 12:21am

Jweb hiding problem when is inside a bpatcher

I have a very annoying problem and I think it is a bug.
I have a jweb object inside a bpatcher that when I try to hide it using scripting it does not!
I ‘ve looked in the forum it has been reported once but no one replied to it…
please any ideas! I really need to sort this out cause I was hoping to use the jweb in order to create interfaces inside bpatchers

Regards
4nt0n

#53505
Nov 24, 2010 at 12:43am

What do you mean by “hide it?”

-Ben

#192441
Nov 24, 2010 at 12:57am

hello Ben!

I mean hide the bpatcher.
I use scripting and the thispatcher object in order to hide the bpatcher that contains the jweb object. ALthough it makes the bpatcher visible it doesn’t change it status to hidden. And is a problem with jweb cause whenI remove the jweb object the bpatcher hides properly.

4nt0n

#192442
Nov 24, 2010 at 1:06am

I am adding the files.
just open the interfacing.maxpat
the music_browser.maxpat is the patch inside the bpatcher in interfacing.

#192443
Nov 24, 2010 at 1:19am

Looks like this is a current limitation for jweb in a bpatcher. The screen doesn’t properly get refreshed when you request to hide the bpatcher.

Some workarounds, send a message directly the the jweb object, or move the jweb’s patching/presentation_rect, or use the bpatcher’s ‘offset’ attribute.

-Ben

#192444
Nov 24, 2010 at 1:32am

I was thinking to use a second thispatcer object in the bpatcher and before hiding the bpatcher to hide the jweb object first. It sounds plausible doesn’t is? Actually I tried it and it works.

4nt0n

#192445

You must be logged in to reply to this topic.