Forums > MaxMSP

jWeb not showing top of webpage ?

April 13, 2010 | 3:33 pm

jWeb is not showing the top of a webpage (appr. 100 px) on my system.

The problem is the same when I open X.Safarien from the examples folder.

Is it a bug in the object or is it on my system ?

Thomas
(Macbook Pro, 3.06 Ghz, Mac OS 10.6.3)


April 13, 2010 | 9:56 pm

Attached is a .jpg showing how jWeb is cutting the top of the page – and it can't be scrolled down.

And here is my patch:

– Pasted Max Patch, click to expand. –

[attachment=129823,369]

Attachments:
  1. Snapz_Pro_XScreenSnapz002.jpg

April 14, 2010 | 5:38 pm

And here is a screenshot of the jweb.maxhelp file as it appears on my screen.
As you can see the upper part of the cycling website is not showing and it is not possible to scroll it down.
It is a very strange problem. Is it a bug in jweb or is it compatibility problems with Max OS Webkit ?

best,

Thomas

[attachment=129937,374]

Attachments:
  1. MaxMSPScreenSnapz002.jpg

April 14, 2010 | 11:27 pm

Just a note about the jweb object, we know there are problems with this object. However, they appear to be Apple’s bugs. We are in the process of a major rewrite, which is the only way to address them, since Apple will not be fixing the bugs.

The jweb object was originally created for our inline documentation browser, so its usefulness beyond that may be a little limited.

-Ben


April 16, 2010 | 6:17 am

OK. Thanks a lot for the answer, Ben !

/Thomas


Viewing 5 posts - 1 through 5 (of 5 total)