Forums > MaxMSP

kill me

September 21, 2006 | 4:53 am

sorry for all the posts today. i get but 1 day off per week. anyway please
can you guys figure this one out? when Waveform~ is attached to this patch
it turns stupid and wont accept any Unit, Snap, or Mode commands. if you
detatch it from the patch it works again. it won’t even work if you set them
from Get info. any help would be dearly loved

thanks,
joel

max v2;
#N vpatcher 274 217 1095 704;
#P window setfont "Sans Serif" 9.;
#P message 32 130 44 9109513 snap grid;
#P hidden message 82 282 29 9109513 set 1;
#P flonum 84 177 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 32 151 43 9109513 unit bpm;
#P button 310 23 15 0;
#P number 338 37 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 338 55 41 9109513 store $1;
#N vpreset 12;
#X append 1 1 11 178 271 flonum float 415.623596 ; 10 178 208 flonum float
274.60318 ;;
#X append 2 1 11 178 271 flonum float 534.376465 ; 10 178 208 flonum float
497.278931 ;;
#X append 3 1 11 178 271 flonum float 1024.263062 ; 10 178 208 flonum float
1009.410461 ;;
#X append 4 1 11 178 271 flonum float 1009.410461 ; 10 178 208 flonum float
0. ;;
#X append 12 1 11 178 271 flonum float 534.376465 ; 10 178 208 flonum float
497.278931 ;;
#P preset 338 81 47 27;
#P message 327 142 42 9109513 0 -1 0 -1;
#P message 31 47 14 9109513 0;
#P message 132 41 43 9109513 startloop;
#P message 132 59 32 9109513 loop 1;
#P message 523 46 26 9109513 read;
#P message 148 22 26 9109513 stop;
#P message 91 22 54 9109513 startwindow;
#P message 46 47 16 9109513 0.5;
#P message 63 65 16 9109513 -1;
#P message 46 65 14 9109513 2;
#P message 63 47 14 9109513 1;
#P newex 82 59 34 9109513 sig~ 1.;
#P user meter~ 134 105 147 174 50 1 149 93 0 0 0 203 255 173 250 30 236 2
246 103 1 197 100 12 3 3 3 3;
#P user gain~ 82 105 50 46 158 0 1.071519 7.94321 10.;
#P newex 149 105 28 9109513 dac~;
#P message 31 185 38 9109513 set jms;
#P flonum 334 179 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 271 178 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 208 178 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 145 178 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P hidden message 332 281 33 9109513 set $1;
#P hidden message 282 281 33 9109513 set $1;
#P hidden message 232 281 33 9109513 set $1;
#P hidden message 182 281 33 9109513 set $1;
#P hidden message 132 281 31 9109513 set $1;
#P newex 523 67 54 9109513 buffer~ jms;
#P newex 82 83 109 9109513 groove~ jms;
#P user waveform~ 81 198 263 74 139 9;
#W mode select;
#W snap grid;
#W mouseoutput continuous;
#W unit bpm;
#W grid -1.#IND;
#W ticks 0;
#W labels 1;
#W vlabels 0;
#W vticks 1;
#W bpm 0. 4.;
#W frgb 1 48 231;
#W brgb 120 181 210;
#W rgb2 61 1 247;
#W rgb3 9 250 255;
#W rgb4 0 0 0;
#W rgb5 125 198 255;
#W rgb6 0 0 0;
#W rgb7 99 99 99;
#P comment -1 29 100 9109513 playback speeds;
#P connect 36 0 1 0;
#P connect 34 0 1 0;
#P connect 13 0 1 0;
#P connect 33 0 1 0;
#P hidden connect 27 0 17 0;
#P hidden connect 20 0 17 0;
#P hidden connect 19 0 17 0;
#P hidden connect 18 0 17 0;
#P hidden connect 21 0 17 0;
#P hidden connect 26 0 2 0;
#P hidden connect 25 0 2 0;
#P connect 17 0 2 0;
#P connect 2 0 15 0;
#P hidden connect 1 0 35 0;
#P hidden connect 35 0 34 0;
#P hidden connect 1 2 2 1;
#P hidden connect 1 1 4 0;
#P hidden connect 15 0 16 0;
#P lcolor 15;
#P connect 9 0 1 1;
#P hidden connect 4 0 9 0;
#P hidden fasten 15 0 14 0 197 173;
#P hidden connect 23 0 14 0;
#P hidden connect 22 0 14 0;
#P hidden fasten 15 0 14 1 215 173;
#P hidden connect 1 3 2 2;
#P hidden connect 1 2 5 0;
#P connect 10 0 1 2;
#P connect 29 0 10 0;
#P hidden connect 5 0 10 0;
#P hidden connect 1 3 6 0;
#P connect 11 0 1 3;
#P connect 29 0 11 0;
#P hidden connect 6 0 11 0;
#P hidden connect 1 4 7 0;
#P hidden connect 1 5 8 0;
#P connect 28 0 1 4;
#P connect 12 0 1 4;
#P connect 32 0 31 0;
#P connect 31 0 30 0;
#P connect 30 0 29 0;
#P connect 24 0 3 0;
#P pop;


September 21, 2006 | 5:34 am

Joel Swensen wrote:
> sorry for all the posts today. i get but 1 day off per week. anyway
> please can you guys figure this one out? when Waveform~ is attached to
> this patch it turns stupid and wont accept any Unit, Snap, or Mode
> commands. if you detatch it from the patch it works again. it won’t even
> work if you set them from Get info. any help would be dearly loved

It does work actually, and the error in the Max window is correct: It
says "message doesn’t understand snap".
It’s not waveform~ which is complaining, but the unused message box
connected to the last outlet. it passes messages on to another
waveform~… But if you put something else there, be sure it understands
it…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


September 21, 2006 | 11:36 am

omg thank you. lol i guess i can chalk that one up to my sloppy organisation

On 9/20/06, Stefan Tiedje wrote:
>
> Joel Swensen wrote:
> > sorry for all the posts today. i get but 1 day off per week. anyway
> > please can you guys figure this one out? when Waveform~ is attached to
> > this patch it turns stupid and wont accept any Unit, Snap, or Mode
> > commands. if you detatch it from the patch it works again. it won’t even
> > work if you set them from Get info. any help would be dearly loved
>
> It does work actually, and the error in the Max window is correct: It
> says "message doesn’t understand snap".
> It’s not waveform~ which is complaining, but the unused message box
> connected to the last outlet. it passes messages on to another
> waveform~… But if you put something else there, be sure it understands
> it…
>
> Stefan
>
> –
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>


Viewing 3 posts - 1 through 3 (of 3 total)