Forums > MaxMSP

korg nanokey recognition/midi input

December 1, 2011 | 4:46 am

just picked up a nanokey on the cheap and can’t seem to figure out how to receive the keypresses (midi-data?) in max. this may have something to do with the setup as any key I press on the nanokey elicits a "ping".


December 1, 2011 | 8:38 am

look into notein…

And do the tutorials…


December 1, 2011 | 12:16 pm

thank you. foolish I guess, but I still can’t make the "ping" go away with every keypress…
this is occurring outside of max as well


December 2, 2011 | 6:36 am

any ideas how to make this pinging stop?, driving me mad…


December 2, 2011 | 12:19 pm

What do you mean by "pinging?" I use the whole nano-series with max regularly with no issues.


December 3, 2011 | 1:54 am

It went away for awhile but now it’s back with a vengeance. The nanokey is functioning fine within max but there is an additional noise (i described it as a ping, I think its some sort of error notification but not one of the standard mac ones) whenever a key is lifted after being being pressed.. thoughts?


December 3, 2011 | 1:59 am

Same thing with the launchpad….

Can’t get rid of it


December 3, 2011 | 9:23 am

Man, I wish I knew more about this stuff… I just plug the usb cables in and everything works. Can you post a patch so we can see if there’s anything else going on?


December 22, 2011 | 4:17 pm

are you guys on mac? it might be the test mode on the Audio Midi Setup utility. I think that pings when it gets data in….


December 22, 2011 | 5:13 pm

In order to associate it with max, just press any key with the annexed patch opened, then you’ll know what is the key’s controller number. Then create a new ctlin object with the number you wish to control. That’s it!

Attachments:
  1. Intester.maxpat

Viewing 10 posts - 1 through 10 (of 10 total)