Forums > MaxMSP

LCD and fullscreen

January 14, 2010 | 9:02 am

Im using the colorblobs object by Charlie deTar (based on Momeni concepts) (Nice interpolation interface) I need it to work for fullscreen. It uses LCD object for visuals. Can the LCD object do fullscreen. Didnt find any in documentation. Any way around?


January 14, 2010 | 10:08 am

not as far as i know…do you have jitter? jit.lcd could do what you need.


January 14, 2010 | 12:11 pm

Ok?! Maybe I could hack the original object and change lcd to jit.lcd. Is it just some "fullscreen" command from a messagebox?


January 14, 2010 | 12:35 pm

Just found out that inside the colorblobs folder there is an object called colorblobs-to-jit.lcd.pat

I return if I have problems implementing it. Thanks for the jitter clue, anyway


January 14, 2010 | 12:57 pm

Are you using jit.lcd with jit.window and messagebox "fullscreen 1"? (By the way what is the key to escape fullscreen. esc doesn work. I had to press command q to get out (and then cancel quiting)


January 14, 2010 | 2:50 pm

Ok. I figured out the escape problem

Another thing:
jit.lcd to jit.window seems to be the solution. jit.window creates a new little window which may appair in fullscreen. jit.window can according to the help-patch it can display mouse-movements from the right outlet when you connect "idlemouse 1" (messagebox) to the input.
When I go fullscreen I would like jit.window to scale up the mouse-detection area to fit the full screen. Currently its only detecting mousemovement in the area where the litle jit.window is positioned before I go into fullscreen. So if the jit.window is originally in the upper right corner of the screen it only detects mouse-movement in this area when I go to fullscreen.
Is there an option for this?


January 21, 2010 | 10:55 am

Solved


February 15, 2010 | 9:27 am

does anyone remember/know the message term for using the esc button as a toggle to activate the fullscreen mode?

i forgot it.


February 15, 2010 | 9:28 am

and how did you fix the problem of togging out of fullscreen mode?


February 15, 2010 | 5:46 pm

for ESC: [key] –> [sel 27] –> toggle fullscreen


February 15, 2010 | 6:40 pm

seejayjames: thanks!


Viewing 11 posts - 1 through 11 (of 11 total)