Forums > MaxMSP

Leap Motion controller and o.io.leap object

December 3, 2013 | 2:18 am

Hey Guys

I’m trying to use my Leap with this new object I found (i.io.leap) and have installed the .mxo and .maxhelp files in the appropriate places but whenever I try to load the .maxhelp file I get the error message:

unable to load object bundle executable
2013-12-03 10:14:19.870 Max[4730:207] Error loading /Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap: dlopen(/Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap, 262): Library not loaded:
Referenced from: /Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap
Reason: image not found

Dont know what I’m doing wrong?
Can somebody please help as I’ve been using the aka.leapmotion object prior to this but it’s totally glitchy and I’ve heard the o.io.leap one is much steadier, it’s for a hand controller granulator so I need precision.

Thanks in advance you good, good people!
:)


December 3, 2013 | 3:01 am

I’m thinking it might be an SDK thing perhaps?
Any thoughts?
:)


December 3, 2013 | 9:21 pm

First, make sure you have correctly installed the o dot packages. (I think you mean o.io.leap and not i.io.leap. ) You can find that download over at CNMAT’s page. http://cnmat.berkeley.edu/downloads

Once you have this working (you can check by making a o.message object and it correctly initializing) you need to make sure that o.io.leap.mxo and o.io.leap.maxhelp are in your path directories. If you are curious what all the data this wrapper has you can use an o.io.broadcast object to list these or I’ll include them below. I hope it works out for you!

o.io.leap- list of data

/Hands
/hand/leftmost/direction/x
/hand/leftmost/direction/y
/hand/leftmost/direction/z
/hand/leftmost/distance/from/rightmost
/hand/leftmost/id
/hand/leftmost/palm/normal/x
/hand/leftmost/palm/normal/y
/hand/leftmost/palm/normal/z
/hand/leftmost/palm/positiony/x
/hand/leftmost/palm/positiony/y
/hand/leftmost/palm/positiony/z
/hand/leftmost/palm/sphere/center/x
/hand/leftmost/palm/sphere/center/y
/hand/leftmost/palm/sphere/center/z
/hand/leftmost/palm/sphere/radius
/hand/leftmost/palm/velocity/x
/hand/leftmost/palm/velocity/y
/hand/leftmost/palm/velocity/z
/hand/leftmost/pitch
/hand/leftmost/roll
/hand/leftmost/yaw
/hand/rightmost/direction/x
/hand/rightmost/direction/y
/hand/rightmost/direction/z
/hand/rightmost/distance/from/leftmost
/hand/rightmost/id
/hand/rightmost/palm/normal/x
/hand/rightmost/palm/normal/y
/hand/rightmost/palm/normal/z
/hand/rightmost/palm/positiony/x
/hand/rightmost/palm/positiony/y
/hand/rightmost/palm/positiony/z
/hand/rightmost/palm/sphere/center/x
/hand/rightmost/palm/sphere/center/y
/hand/rightmost/palm/sphere/center/z
/hand/rightmost/palm/sphere/radius
/hand/rightmost/palm/velocity/x
/hand/rightmost/palm/velocity/y
/hand/rightmost/palm/velocity/z
/hand/rightmost/pitch
/hand/rightmost/roll
/hand/rightmost/yaw
/timeStamp

Kski


December 17, 2013 | 1:19 am

Hi all, same error here.
I’m on MBP 10.8.5 and max 6.1.6.

The odot library seem to work well and o.io.leap.mxo and .maxhelp are in my search path…

When I try to open the help file in max window this message appear:

odot version 1.5b-14-gb7bfb80 (compiled Mon Nov 11 22:46:43 PST 2013), by John MacCallum, Adrian Freed, Rama Gottfried
Copyright (c) 2008-13 Regents of the University of California. All rights reserved.
o.io.leap: unable to load object bundle executable
2013-12-17 10:11:02.549 Max[287:c07] Error loading /Users/pjeve/Documents/MyMax/Libraries/CNMAT/CNMAT_Externals/odot/objects/o.io.leap.mxo/Contents/MacOS/o.io.leap: dlopen(/Users/pjeve/Documents/MyMax/Libraries/CNMAT/CNMAT_Externals/odot/objects/o.io.leap.mx
o/Contents/MacOS/o.io.leap, 262): Library not loaded: @loader_path/libLeap.dylib
Referenced from: /Users/pjeve/Documents/MyMax/Libraries/CNMAT/CNMAT_Externals/odot/objects/o.io.leap.mxo/Contents/MacOS/o.io.leap
Reason: image not found

I need to put the libLeap.dylib in some precise location?

Thanks in advance for the help!


December 18, 2013 | 6:52 am

Hi, I have tried using this object but the problem is I do not have the o.route.mxo

I have downloaded the CNMAT externals library, and this has given me the o.route.maxhelp but not the o.route external.

Can someone link me to where I can get o.route.mxo ???

Cheers, Theo


December 18, 2013 | 8:30 am

it’s weird Theos, i have it here from the latest cnmat distrib


January 2, 2014 | 7:08 pm

Hey guys
I’m still having the same trouble as PJEVE here. I’ve found and installed the o.route.mxo and the Osc max objects but now the i.io.leap object wont load properly stating that: "o.io.leap: unable to load object bundle executable
2014-01-03 03:04:17.058 Max[25989:207] Error loading /Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap: dlopen(/Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap, 262): Library not loaded
: @loader_path/libLeap.dylib
Referenced from: /Applications/Max6/Cycling ’74/max-externals/o.io.leap.mxo/Contents/MacOS/o.io.leap
Reason: image not found"

Really stuck here fellas, would really appreciate a bit of help?! :(
Thanks in advance.
x



bdc
January 2, 2014 | 9:24 pm

You have to run Max in 32-bit mode. Right click and select Get Info, then check the ‘Open in 32-bit mode’ checkbox.


January 3, 2014 | 4:59 am

Hey BDC thanks for your reply, I’ll tried right clicking and clicking the "get info" but there’s no option for opening in 32bit mode? My version of Max is 6.0.4, this is only 32bit isn’t it? :)



bdc
January 3, 2014 | 7:15 am

@JOHNNYC777 – I’m running Max 6.1.6 under Mavericks on a 2012 MBP w/retina display. That’s what got o.io.leap.mxo working for me. Sorry my suggestion didn’t work for you.


January 3, 2014 | 7:24 am

No worries @BDC, thanks anyway dude I appreciate it.
I’m gonna try Max 6.1 and see what happens.
:)


January 21, 2014 | 8:23 am

Hi, a lot of 3rd party plugins only work in 32bit mode at the moment. I think you have to specify at install so may have to reinstall max to change.


January 21, 2014 | 11:43 am

Solved!!

Ok, i don’t know why but i think that there is something wrong in the external located in the package folder.

@ Johnny: Try to use the external.zip in the main git page. This worked for me!

P.S. I’m under OSX 10.8.5 + Max 6.1.6 (32 bit)


March 17, 2014 | 4:58 am

You should give a shot at
http://www.leapformax.com

It’s very lightweight (see tcpigolo.js) and worked very well for us, freeing the max pc from the leap load.


March 31, 2014 | 11:07 am

I guess there is no leapformax solution for a one mac based config running leapmotion + max ?

Edit : Oops, misread the site. I have to test this now !


April 14, 2014 | 6:46 am

Just had the same fun installing o.io.leap
so I thought id confirm the way to get it to work :)

a) download CNMat externals from :http://cnmat.berkeley.edu/downloads
b) extract, add to file preferences… ( you can just add odot if you like)
c) download o.io.leap from https://github.com/derekrazo/o.io.leap/tree/master
(take the whole thing, as will become apparent in a moment)
d) create a new directory for the external, and put in in file preferences
e) extract the zip file, o.io.leap.mxo.zip and take the mxo and put it into (d)
f) copy the maxhelp file in the root and put it into (d)
g) copy o.io.leap-package/support/libLeap.dylib and put it into (d)

hope this helps someone
Mark

note: the issue is the mxo in o.io.leap-package doesn’t correctly reference the dylib, only the one contained in the zip file.
(ive not check yet which version of the mxo this one is, e.g. if it contains the latest code or not, also I’ve not checked if you build it in Xcode if this has the dylib correctly referenced… might be next on my list)


July 5, 2014 | 7:33 am

http://www.leapformax.com
HAS JUST been updated for v6.json
tcpigolo.js AND tcpigola full v6


September 22, 2014 | 3:25 pm

http://www.leapformax.com

Just got updated!
20140922 -UPDATE
-Complete revolution, first of all – Absolutely – NO-MORE-MEMORY-ISSUE.
-The tcpigola max patches are now independent from leapmotion, they can be used for ANY JSON OBJECT
-dict approach – a bit slower but stable- great for unpredictable JSON objects and where you cannot predict the fields you will be interested in reading, also very good for integrating with preexisting dict based systems.
-props approach – very fast – select exacly the fields you want and have them outputted as an array, then you can do whatever you want .. for example unpack it.


September 28, 2014 | 10:50 am

http://www.leapformax.com v0.5 – unlocking performances
and on a minor note website got updated.


Viewing 19 posts - 1 through 19 (of 19 total)