Line ramp time to affect playback speed

Sep 25, 2011 at 2:37am

Line ramp time to affect playback speed

Dear Friends,

I’ve been struggling with this for several weeks now. I’m trying to create a playback bar using line that has variable playback speed. When adjusting the ramp time live, its affect on the speed will be variable based on the playback position of the file. If the file has just started, the impact of the adjusted ramp time will be less. If the file is closer to the end, the affect will be greater. I understand why this is happening, but I’m trying to find a way around it.

I’ve already tried multiplying the time remaining by >1 for FF and <1 for slowdown, but a) I get so many stack-overflow messages and b) when the file has 0 seconds remaining, it gets stuck.

My patch is quite large, and so I’m just “excerpting” an example of the problem spot here. Any help would be greatly, greatly appreciated.

Best,

Timothy Stulman


----------begin_max5_patcher----------
605.3oc0V01ihBCD9y3uBR+LmgVdQ49186XylKUoKa2CaMRMm2sY+uekovhK
JqsJKwynRXJL8Ydlmoy75LOzJ4AVEx+69O36485LOOvTsAul68PanGVWRqfG
CsYeohWUxyY6PAl044vJxUu7snzVih8a3hRlBdKbiwsT05m4hhetisVY1URH
ddXfOYYZ8EbVR8knv4g9O14I4dUqqHMVMlT+YKy3GDJP+68Wphoz6uF4lUCA
merWk63Lghp3RQ8iDVa8sYyp+KvVpfUUQKXsQrhc.hIDNT+o05SRgph+W.kX
hFFmvYKNKkQ9DJKaAPR.UEGCg1xAIL7Q.QP2..A8icbZIZPpz+wqfNDreqCm
SXiRIMeEUTXOgD4rFJCzP.qjBoZR3XxG.7uJNYHIhCxCRlq5CbLTKkZTIj4I
2G5igKWbfLbtXAmABhzn6KxPIKJJYm4DTRhqpeb7x5XaYqt2J0+IgAWnF0xd
c.xx6x1VjZwtG3YcmClDegHmbk08A2R8+SkRMJrmDvN2+LJDJ1SxLc3VL9rf
NFnpaiFFPirk9KcmY8WGHnDm6VhMTC3O+jEie6goQZ39jUQlIqHlIqv+WIMJ
4BlqZi3yxPQeBCQVZFdBN6HIc7InlgROhW.eCgWuwtA7Ua+ijUkb+t0stqQG
32gvbVkhKdeL1G5FC+nG5YddNyLlaikM77sR8Q9MXXfLmsPptq7EwTck6Tho
r6OL0a6NOlhmTHEaAhlVwDN01DGd5DS3OrcmGS8pBlDLcIdpWUvWNlrQf2C3
e0XJxBHMsYNqNs7VJ5z271r+A.aISvC
-----------end_max5_patcher-----------
#59028
Sep 25, 2011 at 3:12am

Could you post your patch so we can see what you have done so far?

#212075
Sep 25, 2011 at 4:29pm

Sure! Here it is. It’s a granular synthesis patch based on Peter Batchelor’s tutorials (which are amazing). The problem described above lies in the “playback” patcher located on the bottom, left-hand side. I’m pasting the patch below, and the external “voice” patch below that. I’d be extremely grateful for any help you could offer. Thanks for your attention!

– Pasted Max Patch, click to expand. –
– Pasted Max Patch, click to expand. –
#212076

You must be logged in to reply to this topic.