Link Max/msp and Reaktor

Aug 7, 2006 at 3:31am

Link Max/msp and Reaktor

Hello everyone,

anyone knows how can make a link from Max/msp to Reaktor 4?

Thanks

aldo r

#27058
Aug 7, 2006 at 6:29am

What kind of link ? Audio or midi ?

#81502
Aug 7, 2006 at 1:10pm

#81503
Aug 7, 2006 at 2:08pm

#81504
Aug 7, 2006 at 2:19pm

>Hello,
>Both…
>I would like to use audio instruments…

THE easiest is to use reaktor as a vst plug-in in max…..

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

#81505
Aug 7, 2006 at 3:03pm

Hello again,

Ok, as a vst pluin in max…

Thanks to everyone

Aldo R

On 07/08/2006, at 08:19 AM, Kasper T Toeplitz wrote:

>> Hello,
>> Both…
>> I would like to use audio instruments…
>
> THE easiest is to use reaktor as a vst plug-in in max…..
>
> kasper
> —
> Kasper T. Toeplitz
> noise, composition, bass, computer
> http://www.sleazeArt.com
>
>

#81506
Aug 7, 2006 at 3:31pm

#81507
Aug 7, 2006 at 3:56pm

#81508
Aug 7, 2006 at 4:03pm

#81509
Aug 9, 2006 at 8:04am

#81510
Sep 17, 2006 at 9:38pm

aldo r –

Tell me how this worked out for you. I am a Reaktor 5 user as well. I am running it as a VST inside Max/MSP no problem, but what I’m strugglig with is how to get it to load with an “ensemble” already loaded up in Reaktor wit its default Snap. Were you able to figure this out? The normal messages (read) and loadbang I use for my other VST effects to them to load presets is not working here.

I was also thinking of trying re-wire of some sort, running Reaktor as a standalonen with MAX/MSP…not sure if I want to run down that path yet.

Kris

Quote: aldorodriguez wrote on Sun, 06 August 2006 21:31
—————————————————-
> Hello everyone,
>
> anyone knows how can make a link from Max/msp to Reaktor 4?
>
> Thanks
>
>
> aldo r
>
—————————————————-

#81511
Sep 18, 2006 at 8:34am

hi

as far as i can tell, using R4 & R5 in max as vst’s work – you first
load the chosen reaktor “shell” ( 8 outs, 2 outs etc) and then the
saved ensemble

it can all be done automatically:

at startup (of the patch) you have reaktor (the chosen flavor) as
argument (if this does not work, not sure if reaktor is ok for this,
load an empty vst~, then a message “plug” with teh name of the R
shell)

then (I usually do it 22 miliseconds later, but mostprobaly anything
goes) message “read
HD/…….(your_filepath_here…)…/myRektorpresets/Rgreatsound ” –
of course you saved, before your ensemble as Rgreatsound in teh
folder myRektorpresets

if you save from inside max the message “write
HD/…….(your_filepath_here…)…/myRektorpresets/Rgreatsound ” is
your friend

it works

best

kasper

>
>Tell me how this worked out for you. I am a Reaktor 5 user as well.
>I am running it as a VST inside Max/MSP no problem, but what I’m
>strugglig with is how to get it to load with an “ensemble” already
>loaded up in Reaktor wit its default Snap. Were you able to figure
>this out? The normal messages (read) and loadbang I use for my other
>VST effects to them to load presets is not working here.
>
>
>
>
>Quote: aldorodriguez wrote on Sun, 06 August 2006 21:31
>—————————————————-
>> Hello everyone,
>>
> > anyone knows how can make a link from Max/msp to Reaktor 4?
>>


Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

#81512
Sep 18, 2006 at 3:51pm

Thanks, Kasper. I thought I had tried this, but let me get some clarification from you since Reaktor is not as cut and dried as a basic VST. This is what I did in my patch, and I’ll add some comments too:

I loadbang: plug “C/khartung/VST Effects/reaktor5.dll”

Comment: I uses this to load the Reaktor VST upon launch of MAX/MSP…works fine. I open it and see the Reaktor 5 shell. I have been manually loading my Reaktor ensembles and snaps (which I wrote prior to all of this)

I loadbang: read “C/khartung/VST Presets/reaktor.fxb”

Comment: Initially, I had opened Reaktor from MAX/MSP, I loaded my ensemble, then loaded my snap. Then I used the Write message to write the reaktor.fxb file. However, the above argument does not load the ensemble, so I tried the following:

I loadbang: read “C/khartung/Reaktor Ensembles/BlackbirdFX (FAV).ens”

“BlackbirdFX (FAV).ens” is the actual ensemble that I had saved a while back. Before I started using MAX/MSP I was using a another VST host (Chainer). Chainer must have had some programming that did all ths for me, because once I loaded Reaktor and my ensemble, that ensemble always loaded by default in the VST host, and I never had to save any fxb file to accomplish this.

Morover, the read comment above does not load the ensemble either.

Now the question is whether I have done what you recommend below.

Kris

Quote: Kasper T Toeplitz wrote on Mon, 18 September 2006 02:34
—————————————————-
> hi
>
> as far as i can tell, using R4 & R5 in max as vst’s work – you first load the chosen reaktor “shell” ( 8 outs, 2 outs etc) and then the saved ensemble
>
> it can all be done automatically:
>
> at startup (of the patch) you have reaktor (the chosen flavor) as argument (if this does not work, not sure if reaktor is ok for this, load an empty vst~, then a message “plug” with teh name of the R shell)
>
> then (I usually do it 22 miliseconds later, but mostprobaly anything goes) message “read HD/…….your_filepath_here…)…/myRektorpresets/Rgreatsound ” –
> of course you saved, before your ensemble as Rgreatsound in teh folder myRektorpresets
>
> if you save from inside max the message “write
> HD/…….your_filepath_here…)…/myRektorpresets/Rgreatsound ” is your friend
>
> it works
>
> best
>
> kasper
>

#81513
Sep 18, 2006 at 4:50pm

ok

so my patch would be

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 398 89 44 196617 del 300;
#P newex 399 68 48 196617 loadbang;
#P message 151 126 239 196617 read BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
#P message 131 73 244 196617 write BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
#N vst~ loaduniqueid 0 Reaktor5.vst;
#P newobj 109 153 157 196617 vst~ Reaktor5.vst;
#P connect 4 0 2 0;
#P connect 3 0 4 0;
#P connect 2 0 0 0;
#P connect 1 0 0 0;
#P window clipboard copycount 5;

it’s on mac so no .dll

and of course the path is mine.. yours will be different

best

kasper

>Thanks, Kasper. I thought I had tried this, but let me get some
>clarification from you since Reaktor is not as cut and dried as a
>basic VST. This is what I did in my patch, and I’ll add some
>comments too:
>
>I loadbang: plug “C/khartung/VST Effects/reaktor5.dll”
>
>Comment: I uses this to load the Reaktor VST upon launch of
>MAX/MSP…works fine. I open it and see the Reaktor 5 shell. I have
>been manually loading my Reaktor ensembles and snaps (which I wrote
>prior to all of this)
>
>I loadbang: read “C/khartung/VST Presets/reaktor.fxb”
>
>Comment: Initially, I had opened Reaktor from MAX/MSP, I loaded my
>ensemble, then loaded my snap. Then I used the Write message to
>write the reaktor.fxb file. However, the above argument does not
>load the ensemble, so I tried the following:
>
>I loadbang: read “C/khartung/Reaktor Ensembles/BlackbirdFX (FAV).ens”
>
>”BlackbirdFX (FAV).ens” is the actual ensemble that I had saved a
>while back. Before I started using MAX/MSP I was using a another VST
>host (Chainer). Chainer must have had some programming that did all
>ths for me, because once I loaded Reaktor and my ensemble, that
>ensemble always loaded by default in the VST host, and I never had
>to save any fxb file to accomplish this.
>
>Morover, the read comment above does not load the ensemble either.
>
>Now the question is whether I have done what you recommend below.
>
>Kris
>
>
>
>Quote: Kasper T Toeplitz wrote on Mon, 18 September 2006 02:34
>—————————————————-
>> hi
>>
>> as far as i can tell, using R4 & R5 in max as vst’s work – you
>>first load the chosen reaktor “shell” ( 8 outs, 2 outs etc) and
>>then the saved ensemble
>>
>> it can all be done automatically:
>>
>> at startup (of the patch) you have reaktor (the chosen flavor) as
>>argument (if this does not work, not sure if reaktor is ok for
>>this, load an empty vst~, then a message “plug” with teh name of
>>the R shell)
>>
>> then (I usually do it 22 miliseconds later, but mostprobaly
>>anything goes) message “read
>>HD/…….your_filepath_here…)…/myRektorpresets/Rgreatsound ” -
>> of course you saved, before your ensemble as Rgreatsound in teh
>>folder myRektorpresets
>>
>> if you save from inside max the message “write
>> HD/…….your_filepath_here…)…/myRektorpresets/Rgreatsound ”
>>is your friend
>>
>> it works
>>
>> best
>>
>> kasper
>>
>
>–
>Krispen Hartung
>Improvisational & Jazz Guitar
>http://www.krispenhartung.com
>Performance Calendar:
>http://www.musi-cal.com/search?performers=Krispen%20Hartung
>info@krispenhartung.com
>Discography: http://www.krispenhartung.com/catalogue.htm

#81514
Sep 18, 2006 at 6:07pm

Quote: Kasper T Toeplitz wrote on Mon, 18 September 2006 10:50
—————————————————-
> ok
>
> so my patch would be
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 398 89 44 196617 del 300;
> #P newex 399 68 48 196617 loadbang;
> #P message 151 126 239 196617 read BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
> #P message 131 73 244 196617 write BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
> #N vst~ loaduniqueid 0 Reaktor5.vst;
> #P newobj 109 153 157 196617 vst~ Reaktor5.vst;
> #P connect 4 0 2 0;
> #P connect 3 0 4 0;
> #P connect 2 0 0 0;
> #P connect 1 0 0 0;
> #P window clipboard copycount 5;
>
> it’s on mac so no .dll
>
> and of course the path is mine.. yours will be different
>
> best
>
> kasper

Hmmmm…this must be a MAC vs. PC/WinXP thing, because I can’t get this to work. I have copied the patch I am using below…just can’t get this to work, even with the delay message in there. Are there any PC/XP users out there making this work?

Kris

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 517 91 44 9109513 del 300;
#P newex 593 54 48 9109513 loadbang;
#P message 593 90 184 9109513 plug “C/khartung/VST Effects/reaktor5.dll”;
#P newex 517 56 48 9109513 loadbang;
#P message 557 121 186 9109513 write “C/khartung/VST Presets/reaktor.fxb
“;
#P message 517 152 185 9109513 read “C/khartung/VST Presets/reaktor.fxb
“;
#P message 503 180 30 9109513 open;
#P message 400 251 50 9109513 disable 0;
#P outlet 324 365 15 0;
#P outlet 292 365 15 0;
#P inlet 433 117 15 0;
#P inlet 406 117 15 0;
#P inlet 322 117 15 0;
#P inlet 300 117 15 0;
#P comment 233 173 50 9109513 effect on;
#P message 249 257 48 9109513 ramp 10;
#P message 230 225 61 9109513 2 0 0 3 1 0;
#P newex 347 227 38 9109513 del 15;
#P newex 347 170 52 9109513 route 0 1;
#P newex 152 138 48 9109513 loadbang;
#P message 347 251 50 9109513 disable 1;
#P message 166 225 61 9109513 0 0 0 1 1 0;
#P message 230 198 61 9109513 2 0 1 3 1 1;
#P message 166 199 61 9109513 0 0 1 1 1 1;
#P user matrixctrl 166 257 72 41 MatrixDefaultCell.pct MatrixDefaultBkgnd.pct 72 41 16 16 4 2 16 16 1 1 48 2 5120 0;
#P newex 292 333 74 9109513 matrix~ 4 2 1;
#N vst~ loaduniqueid 0 none;
#P newobj 334 298 79 9109513 vst~ none;
#P comment 167 173 41 9109513 bypass;
#P connect 26 0 25 0;
#P connect 27 0 22 0;
#P connect 24 0 27 0;
#P connect 15 0 2 1;
#P fasten 15 0 1 1 327 280 408 280;
#P fasten 9 1 6 0 373 191 299 191 299 219 171 219;
#P fasten 9 1 5 0 373 191 235 191;
#P fasten 9 1 20 0 373 210 405 210;
#P connect 1 1 2 3;
#P connect 10 0 7 0;
#P fasten 9 0 4 0 352 191 171 191;
#P fasten 9 0 11 0 352 191 299 191 299 219 235 219;
#P connect 9 0 10 0;
#P fasten 8 0 4 0 157 191 171 191;
#P fasten 8 0 11 0 157 219 235 219;
#P fasten 8 0 12 0 157 249 254 249;
#P fasten 8 0 10 0 157 191 352 191;
#P fasten 16 0 9 0 411 159 352 159;
#P connect 1 0 2 2;
#P connect 7 0 1 0;
#P connect 20 0 1 0;
#P fasten 17 0 1 0 438 159 339 159;
#P connect 21 0 1 0;
#P connect 22 0 1 0;
#P connect 23 0 1 0;
#P connect 14 0 2 0;
#P fasten 14 0 1 0 305 280 339 280;
#P connect 25 0 1 0;
#P connect 2 1 19 0;
#P connect 2 0 18 0;
#P fasten 3 0 2 0 171 307 297 307;
#P fasten 12 0 2 0 254 307 297 307;
#P fasten 5 0 3 0 235 219 157 219 157 249 171 249;
#P fasten 4 0 3 0 171 219 157 219 157 249 171 249;
#P fasten 11 0 3 0 235 249 171 249;
#P connect 6 0 3 0;
#P window clipboard copycount 28;

#81515
Sep 18, 2006 at 6:08pm

Quote: Kasper T Toeplitz wrote on Mon, 18 September 2006 10:50
—————————————————-
> ok
>
> so my patch would be
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 398 89 44 196617 del 300;
> #P newex 399 68 48 196617 loadbang;
> #P message 151 126 239 196617 read BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
> #P message 131 73 244 196617 write BlindSpeed:/Users/ktt/Ongaku_X/testREAKT;
> #N vst~ loaduniqueid 0 Reaktor5.vst;
> #P newobj 109 153 157 196617 vst~ Reaktor5.vst;
> #P connect 4 0 2 0;
> #P connect 3 0 4 0;
> #P connect 2 0 0 0;
> #P connect 1 0 0 0;
> #P window clipboard copycount 5;
>
> it’s on mac so no .dll
>
> and of course the path is mine.. yours will be different
>
> best
>
> kasper

Hmmmm…this must be a MAC vs. PC/WinXP thing, because I can’t get this to work. I have copied the patch I am using below…just can’t get this to work, even with the delay message in there. Are there any PC/XP users out there making this work?

Kris

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 517 91 44 9109513 del 300;
#P newex 593 54 48 9109513 loadbang;
#P message 593 90 184 9109513 plug “C/khartung/VST Effects/reaktor5.dll”;
#P newex 517 56 48 9109513 loadbang;
#P message 557 121 186 9109513 write “C/khartung/VST Presets/reaktor.fxb
“;
#P message 517 152 185 9109513 read “C/khartung/VST Presets/reaktor.fxb
“;
#P message 503 180 30 9109513 open;
#P message 400 251 50 9109513 disable 0;
#P outlet 324 365 15 0;
#P outlet 292 365 15 0;
#P inlet 433 117 15 0;
#P inlet 406 117 15 0;
#P inlet 322 117 15 0;
#P inlet 300 117 15 0;
#P comment 233 173 50 9109513 effect on;
#P message 249 257 48 9109513 ramp 10;
#P message 230 225 61 9109513 2 0 0 3 1 0;
#P newex 347 227 38 9109513 del 15;
#P newex 347 170 52 9109513 route 0 1;
#P newex 152 138 48 9109513 loadbang;
#P message 347 251 50 9109513 disable 1;
#P message 166 225 61 9109513 0 0 0 1 1 0;
#P message 230 198 61 9109513 2 0 1 3 1 1;
#P message 166 199 61 9109513 0 0 1 1 1 1;
#P user matrixctrl 166 257 72 41 MatrixDefaultCell.pct MatrixDefaultBkgnd.pct 72 41 16 16 4 2 16 16 1 1 48 2 5120 0;
#P newex 292 333 74 9109513 matrix~ 4 2 1;
#N vst~ loaduniqueid 0 none;
#P newobj 334 298 79 9109513 vst~ none;
#P comment 167 173 41 9109513 bypass;
#P connect 26 0 25 0;
#P connect 27 0 22 0;
#P connect 24 0 27 0;
#P connect 15 0 2 1;
#P fasten 15 0 1 1 327 280 408 280;
#P fasten 9 1 6 0 373 191 299 191 299 219 171 219;
#P fasten 9 1 5 0 373 191 235 191;
#P fasten 9 1 20 0 373 210 405 210;
#P connect 1 1 2 3;
#P connect 10 0 7 0;
#P fasten 9 0 4 0 352 191 171 191;
#P fasten 9 0 11 0 352 191 299 191 299 219 235 219;
#P connect 9 0 10 0;
#P fasten 8 0 4 0 157 191 171 191;
#P fasten 8 0 11 0 157 219 235 219;
#P fasten 8 0 12 0 157 249 254 249;
#P fasten 8 0 10 0 157 191 352 191;
#P fasten 16 0 9 0 411 159 352 159;
#P connect 1 0 2 2;
#P connect 7 0 1 0;
#P connect 20 0 1 0;
#P fasten 17 0 1 0 438 159 339 159;
#P connect 21 0 1 0;
#P connect 22 0 1 0;
#P connect 23 0 1 0;
#P connect 14 0 2 0;
#P fasten 14 0 1 0 305 280 339 280;
#P connect 25 0 1 0;
#P connect 2 1 19 0;
#P connect 2 0 18 0;
#P fasten 3 0 2 0 171 307 297 307;
#P fasten 12 0 2 0 254 307 297 307;
#P fasten 5 0 3 0 235 219 157 219 157 249 171 249;
#P fasten 4 0 3 0 171 219 157 219 157 249 171 249;
#P fasten 11 0 3 0 235 249 171 249;
#P connect 6 0 3 0;
#P window clipboard copycount 28;

#81516
Sep 19, 2006 at 7:23pm

Krispen Hartung wrote:
> Hmmmm…this must be a MAC vs. PC/WinXP thing, because I can’t get
> this to work. I have copied the patch I am using below…just can’t
> get this to work, even with the delay message in there. Are there
> any PC/XP users out there making this work?

I have a PC but no Reaktor (and work mainly on Mac as you know..), but
if I look at the patch it might be a misstyping in there. It seems there
was either a blank or return after .fxb… Maybe Windows will be
confused with an extra white space at the end of a file name…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#81517
Sep 20, 2006 at 1:28am

I really wish it had been that easy, Stefan. I double-checked and even re-typed the argument for the read message…no luck. But here is the weird thing. If I manually hit my “read” button and open the reaktor.fxb file, it opens the ensemble just fine. Now, why would I be able to do this, but loadbang can’t do it via the read messsage and argument containing the pathway to the same file? I even tried removing loadband, and manually hitting the read button inside the vst patch…still did not work. I’m baffled.

Kris

Quote: Stefan Tiedje wrote on Tue, 19 September 2006 13:23
—————————————————-
> Krispen Hartung wrote:
> > Hmmmm…this must be a MAC vs. PC/WinXP thing, because I can’t get this to work. I have copied the patch I am using below…just can’t get this to work, even with the delay message in there. Are thereany PC/XP users out there making this work?
>
> I have a PC but no Reaktor (and work mainly on Mac as you know..), but if I look at the patch it might be a misstyping in there. It seems there was either a blank or return fter .fxb… Maybe Windows will be confused with an extra white space at the end of a file name…
>
> Stefan
>
> —
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>
—————————————————-

#81518
Sep 20, 2006 at 4:54pm

Krispen Hartung wrote:
> I really wish it had been that easy, Stefan. I double-checked and
> even re-typed the argument for the read message…no luck. But here
> is the weird thing. If I manually hit my “read” button and open the
> reaktor.fxb file, it opens the ensemble just fine. Now, why would I
> be able to do this, but loadbang can’t do it via the read messsage
> and argument containing the pathway to the same file? I even tried
> removing loadbang, and manually hitting the read button inside the
> vst patch…still did not work. I’m baffled.

I see, your in the hell of debugging -;)
Try the following: put the reaktor.fxb inside the search path, and then
have just a [read reaktor.fxb] sent to vst~ (be sure that reaktor itself
is loaded before… Also check that the filename itself doesn’t
accidentially has some “invisible” whitespace…)
If this doesn’t work, rename the reaktor.fxb into something different
and try to load that…

My experience for baffling things which work on other places: its rarely
a bug, it does have a reason but it can be very tricky to find that
reason…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#81519
Apr 22, 2007 at 11:29pm

A bit of a blast from the past here, but I am struggling with the same problem. On a pc, sending for instance the message: read D:/Reaktor/Library/Ensembles/New Additions/Synthesizer/2-Osc.ens to a [vst~] holding Reaktor5 doesn’t load an ensemble. I will get an error message saying “Can’t find..” and then the correct, un-f*cked-with file path.

Like Krispen I have also managed to correctly load the Reaktor5.dll plugin, but that still doesn’t help much, if we can’t remotely open the right ensembles.

Any progress with this since last year?
Andreas.

Quote: Kasper T Toeplitz wrote on Mon, 18 September 2006 10:34
—————————————————-
> hi
>
> as far as i can tell, using R4 & R5 in max as vst’s work – you first
> load the chosen reaktor “shell” ( 8 outs, 2 outs etc) and then the
> saved ensemble
>
> it can all be done automatically:
>
> at startup (of the patch) you have reaktor (the chosen flavor) as
> argument (if this does not work, not sure if reaktor is ok for this,
> load an empty vst~, then a message “plug” with teh name of the R
> shell)
>
> then (I usually do it 22 miliseconds later, but mostprobaly anything
> goes) message “read
> HD/…….(your_filepath_here…)…/myRektorpresets/Rgreatsound ” –
> of course you saved, before your ensemble as Rgreatsound in teh
> folder myRektorpresets
>
> if you save from inside max the message “write
> HD/…….(your_filepath_here…)…/myRektorpresets/Rgreatsound ” is
> your friend
>
> it works
>
> best
>
> kasper
>
>
>
> >
> >Tell me how this worked out for you. I am a Reaktor 5 user as well.
> >I am running it as a VST inside Max/MSP no problem, but what I’m
> >strugglig with is how to get it to load with an “ensemble” already
> >loaded up in Reaktor wit its default Snap. Were you able to figure
> >this out? The normal messages (read) and loadbang I use for my other
> >VST effects to them to load presets is not working here.
> >
> >
> >
> >
> >Quote: aldorodriguez wrote on Sun, 06 August 2006 21:31
> >—————————————————-
> >> Hello everyone,
> >>
> > > anyone knows how can make a link from Max/msp to Reaktor 4?
> >>
>
> —
> Kasper T. Toeplitz
> noise, composition, bass, computer
> http://www.sleazeArt.com
>
>
>
—————————————————-

#81520
Apr 22, 2007 at 11:48pm

Hi.
When your ensemble is loaded in vst~, save it by sending the message “write”
(it will be saved as *****.fxb and not *****.ens).
The message “read *****.fxb” into [vst~ reaktor5.dll] will now load your
favorite ensembles ;)
Cheers.

On 4/22/07, Andreas Wetterberg wrote:
>
>
> A bit of a blast from the past here, but I am struggling with the same
> problem. On a pc, sending for instance the message: read
> D:/Reaktor/Library/Ensembles/New Additions/Synthesizer/2-Osc.ens to a
> [vst~] holding Reaktor5 doesn’t load an ensemble. I will get an error
> message saying “Can’t find..” and then the correct, un-f*cked-with file
> path.
>
> Like Krispen I have also managed to correctly load the Reaktor5.dllplugin, but that still doesn’t help much, if we can’t remotely open the
> right ensembles.
>
> Any progress with this since last year?
> Andreas.
>

#81521
Apr 23, 2007 at 8:34am

For some strange reason using “read ***.fxb” didn’t work… then I saved
an “.fxp” and that definitely did the trick!

Thanks for your help, mate – Cheers!
Andreas

e.g.r. skrev:
> Hi.
> When your ensemble is loaded in vst~, save it by sending the message
> “write” (it will be saved as *****.fxb and not *****.ens).
> The message “read *****.fxb” into [vst~ reaktor5.dll] will now load
> your favorite ensembles ;)
> Cheers.
>
>
>
> On 4/22/07, *Andreas Wetterberg*
> > wrote:
>
>
> A bit of a blast from the past here, but I am struggling with the
> same problem. On a pc, sending for instance the message: read
> D:/Reaktor/Library/Ensembles/New Additions/Synthesizer/2- Osc.ens
> to a [vst~] holding Reaktor5 doesn’t load an ensemble. I will get
> an error message saying “Can’t find..” and then the correct,
> un-f*cked-with file path.
>
> Like Krispen I have also managed to correctly load the
> Reaktor5.dll plugin, but that still doesn’t help much, if we can’t
> remotely open the right ensembles.
>
> Any progress with this since last year?
> Andreas.
>
>
> ————————————————————————
>
>

#81522
Apr 23, 2007 at 2:17pm

.fxp is a single preset, .fxb is a preset bank afaik.

Andreas Wetterberg wrote:
> For some strange reason using “read ***.fxb” didn’t work… then I
> saved an “.fxp” and that definitely did the trick!
>
> Thanks for your help, mate – Cheers!
> Andreas
>
> e.g.r. skrev:
>> Hi.
>> When your ensemble is loaded in vst~, save it by sending the message
>> “write” (it will be saved as *****.fxb and not *****.ens).
>> The message “read *****.fxb” into [vst~ reaktor5.dll] will now load
>> your favorite ensembles ;)
>> Cheers.
>>
>>
>>
>> On 4/22/07, *Andreas Wetterberg*
>> > wrote:
>>
>>
>> A bit of a blast from the past here, but I am struggling with the
>> same problem. On a pc, sending for instance the message: read
>> D:/Reaktor/Library/Ensembles/New Additions/Synthesizer/2- Osc.ens
>> to a [vst~] holding Reaktor5 doesn’t load an ensemble. I will get
>> an error message saying “Can’t find..” and then the correct,
>> un-f*cked-with file path.
>>
>> Like Krispen I have also managed to correctly load the
>> Reaktor5.dll plugin, but that still doesn’t help much, if we can’t
>> remotely open the right ensembles.
>>
>> Any progress with this since last year?
>> Andreas.
>>
>>
>> ————————————————————————
>>
>>
>
>

#81523
Apr 23, 2007 at 4:19pm

Yes, I know – thankfully it doesn’t matter much in Reaktor-land, since
presets are stored inside the ensemble itself.

Andreas.

Andrew Burgess skrev:
> .fxp is a single preset, .fxb is a preset bank afaik.
>
> Andreas Wetterberg wrote:
>> For some strange reason using “read ***.fxb” didn’t work… then I
>> saved an “.fxp” and that definitely did the trick!
>>
>> Thanks for your help, mate – Cheers!
>> Andreas
>>
>> e.g.r. skrev:
>>> Hi.
>>> When your ensemble is loaded in vst~, save it by sending the message
>>> “write” (it will be saved as *****.fxb and not *****.ens).
>>> The message “read *****.fxb” into [vst~ reaktor5.dll] will now load
>>> your favorite ensembles ;)
>>> Cheers.
>>>
>>>
>>>
>>> On 4/22/07, *Andreas Wetterberg*
>>> > wrote:
>>>
>>>
>>> A bit of a blast from the past here, but I am struggling with the
>>> same problem. On a pc, sending for instance the message: read
>>> D:/Reaktor/Library/Ensembles/New Additions/Synthesizer/2- Osc.ens
>>> to a [vst~] holding Reaktor5 doesn’t load an ensemble. I will get
>>> an error message saying “Can’t find..” and then the correct,
>>> un-f*cked-with file path.
>>>
>>> Like Krispen I have also managed to correctly load the
>>> Reaktor5.dll plugin, but that still doesn’t help much, if we can’t
>>> remotely open the right ensembles.
>>>
>>> Any progress with this since last year?
>>> Andreas.
>>>
>>>
>>> ————————————————————————
>>>
>>>
>>>
>>
>>
>
>
> .
>

#81524

You must be logged in to reply to this topic.