Forums > MaxMSP

little problem in controlling clips Max to Live 7

October 20, 2008 | 8:30 am

Hello everyone, I have a little problem with this patch.
The aim is to control the triggering of several clips in Ableton Live via a preset object and a matrix in Max.
The clips should be in gate mode launch, so when there is a value ==127 the clip is playing, when there is a value== 0 the clip stops.

Works fine when I use the matrix, but if I use the preset to trigger multiple values in the matrix I simply do not recieve all the "triggerings" in Live.
So to say not all the clips which should be triggered are triggered.
I tried to see if there was a lack of sent information from Max, but via a print object I saw that Max actually outputs all the data.
My question is if the problems lies
1)in the amount of data sent (then I suppose I could use a routing method which outputs only values which have actually changed)
2) in a patching problem (organization of the patch data)
3) limited amount of MIDI data sent/recieved by Max/Ableton
4) all together
5) something else.

the patch is still in an embrional stage so any suggestion is more than welcomed!

To assign and test it with Live you have to put Live in MIDI learn, trigger a cell in the matrix, then exit MIDI learn in Live, and set the just assigned cell back to zero, repeat the procedure for every assigned clip.
Clips should be in gate launch mode

ciao !

– Pasted Max Patch, click to expand. –

March 2, 2009 | 10:54 pm

I am totally new to MAX and want to do something like this. Create a sort of Auto DJ max patch that starts random clips in max. Could you post the .maxpat?

Cheers!



EMV
March 6, 2009 | 8:38 am

The garbled text you see above _is_ the maxpat. Just select and copy (ctrl-c) everything in between the "begin/end max 5 patch" parts and choose "New from Clipboard" in the Max/MSP file menu. Voila, the patch magically appears.


Viewing 3 posts - 1 through 3 (of 3 total)