Forums > Max For Live

Live audio exporting problem

March 16, 2014 | 6:00 pm

Hey guys,

I have a problem when trying to export audio with live.
I have a M4L device that record audio in a buffer in real time (triggered by a midi note), and a groove~ object that loops and plays it. It sort of a beat repeating device.

Whenever I try to export the file to wav, I hear only "empty" audio without groove loops, like if there was no max device at all –although I hear the loops when audio plays in real time!

Sorry for posting no patch, it’s quite a (too) complicated one to show as an example.
Does anyone have an idea?

Lucas


March 17, 2014 | 2:15 pm

If you send a "write" message to the buffer, it should save the audio to a .wav/.aif file. I’m assuming you know you cannot export from the groove~ object itself.


March 17, 2014 | 2:50 pm

I know that groove cannot export audio, but I didn’t know that live off-line rendering would not work


March 17, 2014 | 3:31 pm

Tetsuo, I understand now that you are talking about Ableton’s export. Yes, that sounds correct that certain M4L audio device’s won’t render correctly. I would think the midi could be rendered, but maybe Ableton doesn’t know what to do with the buffer or groove object? Actually, I don’t really know why that is? Good question!


March 17, 2014 | 6:36 pm

I also tried real time rendering, without success.
The only solution seems to use sfrecord~ to resample the part processed with groove~

If anyone has a prettier solution, please share it!


March 17, 2014 | 8:03 pm

I do know that you could build something with live.tab, live.slider, etc. that would be visible to Ableton, and recordable as automation.


March 18, 2014 | 6:55 am

Every single parameter is setted as live object (knobs, number boxes etc)
Autmation is then possible, the only problem being buffer/groove
There’s apparently no buffer~ designed for off-line rendering in Live.

Waiting for a live.buffer~ object :P


Viewing 7 posts - 1 through 7 (of 7 total)