live.button behaves as toggle in automation

Feb 16, 2010 at 10:03pm

live.button behaves as toggle in automation

In this patch I have a button. Through the Live-midi-automation I want to bang it with a note-command. The funny thing is that the button behaves as a toggle. The note switches it on, the next note switches it off (!) and it only bangs once. On mousecontrol all is as expected, so no problems.
Did I overlook something?

Thanks

Peter

#48534
Feb 16, 2010 at 10:53pm

I’ve noticed the same thing. My workaround was to use another button in a feedback configuration to turn the toggling button off, like so:

– Pasted Max Patch, click to expand. –

It’d be nice to get some official response on this strange behavior, though.

#174556
Feb 16, 2010 at 11:06pm

Currently, there is no “trigger” mode for live.button and live.text for automation purposes, just off and on.

-Ben

#174557
Feb 16, 2010 at 11:36pm

No trigger-mode for a button? What else should you do with it? But the workaround is nice and works fine. Thanks, nonagon, for that.

Peter

#174558
Feb 17, 2010 at 12:50am

In the inspector you can set the live.button to send a bang for both on and off. It’s the last item in the inspector

#174559
Feb 17, 2010 at 9:50pm

But the intention was to send 1 bang and be prepared for the next one.
Now it takes 2 triggers for the process. And that is regardless the trigger option.
But please correct me of I’m wrong.

Peter

#174560
Mar 1, 2010 at 1:25pm

is there any plans to impliment a trigger mode for live.button?
i’m using it, or at least i wanted to use it, as part of a key map ( an auto fadein fadeout (linked to bpm / bar length) for the volume of each channel) i have a live button for each channel to start the fade, with a mouse click it works fine but i want to key map it to the number pad (key 1 for channel 1 etc) on my keyboard but all it does is act as a toggle – i.e i have to hit the 1 button again to turn it off (and it doesn’t send a bang)
i did think of using key and select to map in the same way but i have to be clicked on the m4l object for these to work (doesn’t work well when i’m using my launchpad as well for clip starting)
anyone know to hardwire from the keyboard to a button using the api?

karl

#174561
Mar 1, 2010 at 2:36pm

It’s on our feature request list, but it also will probably not be added in the foreseeable future. In the meantime, you can fake it:

– Pasted Max Patch, click to expand. –
#174562
Mar 1, 2010 at 3:05pm

thanks for that – i did try something similar but it doesn’t seem to work (it turns off the button led) but isn’t starting a fade when i map it to the 1 key.
very strange – i’ve attached the patch to let you see. the patch will fadein / fadeout the first 3 channels of abelton (loadbang is fade out). i put your button at the bottom (fades on channel one) – when you click it with the mouse all good – fade out happens – when you map it to the 1 key (or any key) the button lights (and turns off) and the max button bangs but no fade?

#174563
Apr 3, 2010 at 5:13pm

I had the same problem.
I found that there was a conflict from having the qwerty-keyboard midi keyboard as midi-input turned on.

I turned off “Midi From…. Computer Keyboard” on that channel, and now everything works.

#174564
Sep 1, 2013 at 3:28pm

Please someone let me know if this has been fixed yet (in Max6)? I am running 5.1.9 but it is still a problem.

#263924
Apr 11, 2014 at 10:07pm

I would also like to know if this has been fixed in Max 6. I’m struggling with this issue currently. Emmanuel’s suggestion does not seem to work in all instances (for example in a device of mine certain buttons are supposed to disable themselves once they’re clicked and this seems to cause problems.) I’ve had customers tell me that the new version I sent them which aimed at fixing this issue can sometimes crash in Max 6. I have not witnessed this problem as I’m stuck with 5 at the moment. I’d be quite glad to know if there were any changes at all made in 6 concerning this issue (possibly in the way the button handles a “set 0″ message as in Emmanuel’s patch?)

Thanks,
Ryan

#286454
Apr 12, 2014 at 7:34pm

Or is it possibly something that’s changed with Live 9 vs 8?

#286499
Apr 13, 2014 at 12:44am

@Ryan : is it a problem with your sample randomizer ?

#286507
Apr 13, 2014 at 4:04pm

Stephane: Yes. The issue was brought to my attention by customers of my Subtractive Looper, but it was in both of these devices that I had tried to implement Emmanuel’s patch. Have you noticed the problem I described in the Randomizer? I was able to reproduce it once. It seems that if you click one of these buttons fast enough your upclick will arrive before the delayed “set 0″ message, which for some reason can then lead to the button continually triggering itself every 50 ms (even though the buttons are set to bang on zero>one not both.) I really don’t understand fully, but I believe I’ve come up with a fix, which is to simply remove the [delay 50]. It seems to work and I’ll be sending out an update momentarily.

#286559
Apr 13, 2014 at 5:22pm

Even with the delay removed and the button set to bang on Zero->One, the upclick (only if you don’t click fast enough) causes the button to trigger again. This double-triggering is annoying but for now it will have to suffice. Any ideas? This has been way too frustrating for something so trivial.

#286560

You must be logged in to reply to this topic.