Loading Audio Unit / Component plugins

Jan 29, 2013 at 4:55pm

Loading Audio Unit / Component plugins

Hello,

I would like to open plugins that are stored on my disk in Library/Audio/plug-Ins/Components.

I thought plugs in this folder where Audio Unit plugin ; but the vst~ object is not able to open these plugins.

So here are my questions :
- Components plugins are not Audio Unit plugin ?
- How can I open these Components plugins ?

Thanks.

#66196
Jan 29, 2013 at 10:05pm

What audio unit plugins did you try? Component files are a type of bundled file and audio units are bundled as components. You should be able to open AU’s with the vst~ object. What audio units did you try?

GW

#238271
Jan 29, 2013 at 10:48pm

I’ve come across a few AU’s that vst~ wont load, giving a ‘no format AudioUnit exists’ error – most of U-he’s plugs, for example.
Apparently this is connected to multiple plugs being package into a single file, or something – see this post for more: http://www.kvraudio.com/forum/viewtopic.php?t=354478&postdays=0&postorder=asc&start=1185
I’d be interested to know what Dan is referring to when he says Cycling does provide a way to access these plugs…
Cheers
Roger

#238272
Jan 30, 2013 at 10:04am

There is also the au~ external http://www.michaelnorris.info/software/au.html , you may have a try with that.

#238273
Jan 30, 2013 at 10:50am

Hello,

Thanks to all your replies !

@gwsounddsg : I tried a lot of AU plugins (for example +binaural.component from soundhack, or Absynth 5.component from Native Instruments).
When I install an AU plugin, I always have a Plug.component added in my library, that’s why I’m focusing on .component files. Actually no .component plugin works, I’ve got more than 400 of them. But in ABleton Live these plugins work, and are put in “Audio Unit” folder.

@roger.carruthers : so for me, none of the 440 plugs work… I’m correct AU plugs are in Libraray/Audio/Plug-INs/Components ? Some should work, you say…

@LSka : I tried the au~ external. It works for some plugs, but I’m not able to access all my plugs – even if the “bad” plugs work under Ableton Live, under “AU” section.

Thanks.

#238274
Jan 30, 2013 at 10:58am

@LSka : the au~ gives me the list of files put in /VST folder I think (+some extra AU not put in /Components). I can’t find a folder dedicated to explicit AU plugins (such as .aufx ?).

#238275
Jan 30, 2013 at 11:15am

.component is an audiounit, there is no other dedicated extension.

If you double click on the vst~ object after you load the plugin via message “plug”, the main plugin window will open. You can also open the main window via “open” message.

#238276
Jan 30, 2013 at 3:38pm

It occurs to me that the OP might not have Max6. Earlier versions do not load AudioUnits (.component files) unless you have Tim Place’s au~ external.

In addition, it’s good to remember that if your vst/audiounit has spaces in its name, you need to use quotation marks around it for it to load properly: [vst~ "Plugin Name.component"]

#238277
Feb 5, 2013 at 2:20pm

@roger.carruthers – Hi Roger! Regarding the “multiple plugins per .component file” issue – what I was alluding to in that KVR thread is that in Max 6, when you start the app, it automatically creates a list of all of your AU plugins currently in your /Library/Audio/Plug-Ins/Components folder. It puts this list into ~/Library/Application Support/Cycling ’74/AudioUnits/ , and the list of plugins is represented as .auinfo files, These .auinfo files are used to populate the “file” submenu of the “wheel” that appears to the left of the vst~ object within Max.

You will note that Max correctly pulls out multiple .auinfo files from .components that have multiple plugins within them – for example, Uhe’s Zebra2.component gives rise to three .auinfo files (plugins) – Zebra2.auinfo, Zebralette.auinfo, and ZRev.auinfo. For these plugins, you should load them into the vst~ object using either the wheel, or specify them using the .auinfo name (e.g. vst~ Zebra2.auinfo). If you try with vst~ Zebra2.component , you will get an error.

Hope that helps. For the original poster, I think lowenstern’s comment above about the necessity of quotes around filenames with spaces in them is probably the key…

Dan

#238278
Feb 5, 2013 at 6:48pm

Hi Dan, thanks for that – I’d never really noticed the file menu in the wheel; Max 6 is full of surprises!
Anyway, sadly not a solution that applies to standalones, which was my problem, though it’s good to know there is a workaround in Max itself.
Is this something that Cycling could/should see to with vst~ ?
Cheers
Roger

#238279
Feb 5, 2013 at 7:02pm

Hello,

thanks to all of you for all your replies. Sorry I was busy for work this week, I did not have time to reply.
I will try to solve my problem using all of your popoal and let you know.

Thanks again for your help, that’s really nice !

Bye

#238280
Feb 5, 2013 at 10:33pm

@Roger – for sure it would make things simpler is there was some way directly within vst~ to get at these types of plugins, but there are workarounds, even for a standalone; for example, you could populate a umenu with the contents of that AudioUnits folder (it also gets created in a standalone’s Application Support folder, i.e. ~/Library/Application Support/YOUR_APP_NAME/AudioUnits/ ), and then use that to load the AU into the vst~….

#238281
Feb 6, 2013 at 12:55pm

Nice one! That’s a win-win because it also puts both AU and VST plugs into one folder, whereas at the moment I’m having to use a script to switch between vst and au menus.
I wasn’t seeing an Application Support folder for my standalone, but guessed that it might be connected to the database attribute in the standalone object (which rather unhelpfully just gives ‘database’ as an explanation in the documentation!), and checking that seems to have done the trick.
I’m also having a look through your Expo74 standalone presentation, which is full of useful stuff, so thanks again,
Roger

#238282
Feb 6, 2013 at 4:29pm

The standalone folder in the Application Support folder is created by setting the Preferences File Name attribute in the standalone object to be equal to your app’s name…

#238283
Feb 6, 2013 at 4:40pm

Yes, I got that (once I looked in the right Library folder!), but without the database attribute ticked, it doesn’t produce the Audiounits folder; should be in the documentation, really.
It also seems I was a bit hasty about wishing the VST’s and AU’s into one folder; the wheel menu manages to do that, but it’s obviously more complex than just populating a menu from the auinfo folder.
No worries though, it’s still a lot better picking up all the AU plugs this way,
cheers
Roger

#238284
Feb 6, 2013 at 5:59pm

Didn’t know that about the AudioUnits folder not being created without the database attribute ticked, thanks!!

#238285
Aug 9, 2013 at 4:07pm

so I am still not able to plug Ambience reverb unit by Smartelectronix into vst~. I am running MaxMSP in 64bit mode rewired to Logic Pro X. I get the ‘Ambience.auinfo: no format AudioUnit exists’ error.

The plugin I am using is 64bit, loads and functions perfectly in Logic Pro X.

What am I missing here?

#258470
Aug 12, 2013 at 4:44am

Did you try loading the AU using the wheel? It may be that the 64 bit version has a unique .auinfo name that you are not aware of…

#258638
Sep 6, 2013 at 9:55am

Well, that’s what I was trying to do and it didn’t work. But now I have a problem even stranger. I can see no list by using the wheel. When I click on the ‘files’ on the wheel, it simply does nothing. What does this have to do with?

#264498
Sep 6, 2013 at 10:23am

Not sure I’m afraid…

#264499
Sep 6, 2013 at 10:31am

Hey guys, is the vst~ help file “plugin Names” tab not working right? This kind of JS access to the DB is how it is envisaged that plugin names may be harvested by standalones.

From a comment in the JS

/*By default, the Max database is not used by the Max runtime or in standalones.

If you wish to enable the database for use in a standalone, check the “Database” attribute in the inspector for the standalone object

If you wish to enable the database in the Max runtime application, create a text file in the c74:/init folder and add the following line to it:

max db.enable 1;

*/

Also – it’s working fine for me in x64 Mac.

-A

#264500
Sep 6, 2013 at 10:44am

Hi Andrew,

Does the Max database know whether the plugin is an effect or an instrument? If so, how might one tweak the Javascript to get at that info – ideally to separate effects and instruments into two different menus?

#264502
Sep 6, 2013 at 11:35am

Hi Dan,

No I don’t think there is a crossplatform way to do that in Max currently

-A

#264514
Sep 6, 2013 at 11:37am

I settle for Mac only to start? :-)

#264515
Mar 14, 2014 at 6:57am

@Dan Nigrin — having the same problem– I am not able to access some of my *.component plugins, (no spaces, that is not the problem). Here’s a question about what you wrote about the .auinfo files…

Regarding the “multiple plugins per .component file” issue – what I was alluding to in that KVR thread is that in Max 6, when you start the app, it automatically creates a list of all of your AU plugins currently in your /Library/Audio/Plug-Ins/Components folder. It puts this list into ~/Library/Application Support/Cycling ’74/AudioUnits/ , and the list of plugins is represented as .auinfo files, These .auinfo files are used to populate the “file” submenu of the “wheel” that appears to the left of the vst~ object within Max.

The .auinfo files for the non-working plugins are simply not being created (checking in directory ~/Library/Application Support/Cycling ’74/AudioUnits/..)

Any idea why that might be happening ?

#283866
Mar 14, 2014 at 6:57am
#283867
Mar 16, 2014 at 4:29am

Not sure really – are there NO .auinfo files, or just not the ones for a set of specific plugins you’re interested in? If the latter, then perhaps those plugins are not passing some sort of AU validation or something? Just guessing.

#283997
Mar 23, 2014 at 11:53am

Hello,

using the object vst on Max 64 bit i can’t load Tal-Reverb-2. Actually i can load it if i choose the .component file by plug message. If i write the component name like “vst~ Tal-Reverb-2″, it doesn’t work.

I tried the 32 bit plug in version with max 32 bit mode and everything’s good. Can anyone help me to find out the correct name to put on vst~?

Thanks

#284686
Mar 23, 2014 at 11:55am

P.s. there’re not the .auinfo files in ~/Library/Application Support/Cycling ’74/AudioUnits/ …

#284687
Mar 23, 2014 at 12:01pm

I sorted it… I put the full path into vst~ and now it works. Is there a way to get the short name?

#284691
Mar 23, 2014 at 12:27pm

Can’t use audio units in MaxMSP. I can’t see them in /Library/Audio/Plug-ins nor can I use them by creating the object vst~ with a plug-in name. Any solutions?

PS: using Max 6.1.6

#284694
Mar 23, 2014 at 12:51pm

OK, the problem was with AUMatrixReverb. Only works in 64-bit mode…

#284699

You must be logged in to reply to this topic.