Forums > MaxMSP

loadmess prefix / open

April 15, 2012 | 4:10 pm

Hallo everyone,

I want to play a sound file (called Ambiance1.wav) through splay~

It is in the same folder as the max patch on my computer.

I trigger it with message ‘open ambiance1.wav’ but that doesn’t work.
I also tried object loadmess: ‘loadmess prefix ./Ambiance1.wav’ and that doesn’t work.

How can I open the .wav file without using message ‘open’? (I want the maxpatch to open the right .wav by itself)


April 15, 2012 | 4:57 pm

Hello,
Try "loadmess open Ambiance1.wav", it should work.


April 15, 2012 | 5:38 pm

i thought the same way when i first started with max, it doesnt check for what objects to use that are in the same folder as the patch, it needs a directory to look up.
so go to options -> file preferences
then click the little "+" sign at the bottom left corner, it should say "add path" if you hold your mouse cursor over it, then select what path your file you want to use is in.

THEN, do what pierre said.

– Pasted Max Patch, click to expand. –

April 15, 2012 | 5:41 pm

what i like to do is just have a couple folders organized, like one for external objects, one for soundfiles, etc. then just add the files you want to use in that directory and then if the directory is new, add it to the ones to check in when max starts up.
by the way, you have to change the message from "open mywave56.wav" to "open ambiance1.wav"


April 15, 2012 | 6:49 pm

Wouw, tnx a lot!


Viewing 5 posts - 1 through 5 (of 5 total)