Forums > Max For Live

Looper with Max For Live ignoring quantization?

May 13, 2013 | 7:24 am

Have come up against an interesting problem – When controlling the Looper with M4L – the looper quantization settings seem to have no effect on looper controls triggered by max (record, overdub, play, etc) they occur instantaneously, regardless of the quantize setting.

If you click the same buttons on the GUI, the looper behaves as expected and obeys the quantization setting – record waits to the next bar or whatever you have set to begin recording.

Any experience with this or ideas on how to get it to work properly?

thanks!


May 28, 2013 | 3:28 pm

anyone else experience this?

thanks!


May 31, 2013 | 4:09 pm

Yep, that always been a problem.
BTW, did you already check this looper ? It works like Looper in many ways, but it creates loops in clips.

http://www.tete-de-son.com/?p=872


June 1, 2013 | 12:21 am

Hehe… Just bought your device, Valium. Didn’t have time to test it extensively and I hope the timing is really tight.


June 26, 2014 | 8:08 am

I am moving controls for a rack of 8 loopers onto the Push grid with the PDK, and all I have to do is figure out how to get the quatization of the looper (or global as a fallback), and then delay setting the "State" until the quantized time has come. Ideally this would be sample accurate.

I thought I would post a note here, but I guess I’ll start a new thread about sample-accurate timing in M4L.


June 26, 2014 | 9:37 am

Does [pipe 128n @quantize 1n] or [delay 128n @quantize 1n] do what you want?

– Pasted Max Patch, click to expand. –

June 26, 2014 | 11:04 am

Christopher, this is totally killer. I didn’t realize that @quantize would automatically sync with Live’s transport. That’s a huge help!


Viewing 7 posts - 1 through 7 (of 7 total)