Forums > MaxMSP

Looping the same movie with different looppoints but at the same time…

January 11, 2011 | 9:32 pm

hello,

Once again a question about jitter. Sorry for the wacky title but i was out of inspiration. Last week i was approached by a classmate to collaborate on an idea. No, not looking for easy grades or handouts (plus i know a lot more about max than my teacher, in fact i think i can teach him by now :) but i ran into some issues performance-wise.

This idea involves a movie of n.pixels wide and of n sec. length (duration). For example the movie is 200×200 pixels and 120 sec. long. I need to display "strips" of 1 pixel in width and 200 pixels in height (like vertical window-blinds). Every strip has to loop every 120(duration)/200(width) sec. which would have it loop every 600 ms. The first strip loops from 0 to 600ms, the second from 600 to 1200ms and so on.

This is exactly where it gets tricky because as you can see in my patch i load in n# of jit.qt.movies just because of the looping. The videos to be used are 177×144 pixels and despite their size it’s still too much to handle and is terribly slow. Is there a way to circumvene this? I can’t think of any other (more efficient) way other than using the jit.movie or jit.matrixset maybe, but my guess is this will still drain quite some (probably too much) cpu too?

I am open to suggestions, i remade the thing in processing which i deemed more capable for this task and the results were a bit better but it was still extremely slow. I hope i’ve explained it well, it was hard to formulate.

Thanks for reading and hopefully answering,
FRid

mainpatch
(don’t worry, no 200 or 177 pixel video in this one, i made a 10×10 test setup)

– Pasted Max Patch, click to expand. –

Subpatch – save this as- testhelperforum.maxpat

– Pasted Max Patch, click to expand. –

Viewing 1 post (of 1 total)