Forums > Jitter

loopnotify bug?

March 4, 2009 | 10:25 am

Hi,
I have seen some post about this but nothing that could help.

I’m playing a movie using jt.qt.movie, with the message looppoint I can play different loops.

Loop 1: a guy comes
Loop 2: a guy stand still
Loop 3: a guy goes away

I "simply" need my loop 2 to play, using a sensor when you come near the screen the guys goes away (loop 3) and stay there (so far no problem) , once you go away from the screen the guys comes back (loop 1) and then stay still (loop 2).

So I need to be able to play Loop 1 and straight after loop 2 (and keep playing loop 2).

I have use loopreport 1 and "route loopnotify" but here is my problem, by the time I receive the "loopnotify and use it to trigger my loop 2 the first frame of loop 1 is played…

I tried using timereport but it slow down my all patch (the movie is full HD and pretty big).

Is there an other (better) way of doing it?

thanks

b.


March 4, 2009 | 5:18 pm

sometimes when the looping mechanisms are not cutting it, it’s better to turn looping off and explicitly trigger everything yourself using the current frame (retrieved with gettime and some math), and some , and togedge objects.

here’s a patch that shows some of the math, in case it helps.

– Pasted Max Patch, click to expand. –

March 4, 2009 | 6:02 pm

thanks for that, I’ll try this out Wink

b.



azs
March 4, 2009 | 10:52 pm

You could also just save the loops and three different quictimes and trigger the same jit.qt.movie object to read the correct movie when the right conditions are met.


March 4, 2009 | 11:21 pm

Yeah but because my movie is full HD (1888px by 1062px) this would get slow and I wanted to know this if I work with more loops sopme day!

The patch above works just great!

thanks,

b.


Viewing 5 posts - 1 through 5 (of 5 total)